summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2007-08-18 18:36:28 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2007-08-18 18:36:28 +0000
commit7a1eb77e0803ad2f49fa04d7a3e5c92cd0219462 (patch)
treec18ad4cf610c841f3bd0f60fe4274cedf5dc57c3 /dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild
parentGatt has been fixed in trunk to support higher boost versions, so adjusting D... (diff)
downloadhistorical-7a1eb77e0803ad2f49fa04d7a3e5c92cd0219462.tar.gz
historical-7a1eb77e0803ad2f49fa04d7a3e5c92cd0219462.tar.bz2
historical-7a1eb77e0803ad2f49fa04d7a3e5c92cd0219462.zip
version bump wrt bug 158633, thanks to Jakub Moc
Package-Manager: portage-2.1.2.11
Diffstat (limited to 'dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild')
-rw-r--r--dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild b/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild
new file mode 100644
index 000000000000..ba74b73b46a0
--- /dev/null
+++ b/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-DB_DataObject/PEAR-DB_DataObject-1.8.7.ebuild,v 1.1 2007/08/18 18:36:28 hoffie Exp $
+
+inherit php-pear-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="An SQL Builder, Object Interface to Database Tables."
+LICENSE="PHP"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND=""
+RDEPEND=">=dev-php/PEAR-DB-1.7.6-r1
+ >=dev-php/PEAR-Date-1.4.3-r1
+ !minimal? ( >=dev-php/PEAR-Validate-0.5.0-r1
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+src_unpack() {
+ unpack "${A}"
+ # don't install windows-only stuff
+ sed -re 's:<file baseinstalldir="DB" md5sum=".{32}" name="scripts/DB_DataObject_createTables.bat" role="script" />::' -i package.xml || die "sed failed"
+}