summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-31 22:32:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-31 22:32:52 +0000
commitde848fde0810721ff4d537eb2db09968ab0d0b0f (patch)
tree26e8cba6d5fed88e89dcada2694c639bac62a25d /dev-php/mod_php/mod_php-4.3.2.ebuild
parentVersion bump. (diff)
downloadhistorical-de848fde0810721ff4d537eb2db09968ab0d0b0f.tar.gz
historical-de848fde0810721ff4d537eb2db09968ab0d0b0f.tar.bz2
historical-de848fde0810721ff4d537eb2db09968ab0d0b0f.zip
Version bump.
BerkDB is disabled due to DB4 issues and changes in PHP 4.3.2 presently. If you need BerkDB support, please do NOT upgrade at this time.
Diffstat (limited to 'dev-php/mod_php/mod_php-4.3.2.ebuild')
-rw-r--r--dev-php/mod_php/mod_php-4.3.2.ebuild104
1 files changed, 104 insertions, 0 deletions
diff --git a/dev-php/mod_php/mod_php-4.3.2.ebuild b/dev-php/mod_php/mod_php-4.3.2.ebuild
new file mode 100644
index 000000000000..5cead6638e65
--- /dev/null
+++ b/dev-php/mod_php/mod_php-4.3.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.2.ebuild,v 1.1 2003/05/31 22:32:49 robbat2 Exp $
+
+inherit php eutils
+
+IUSE="${IUSE} apache2"
+
+DESCRIPTION="Apache module for PHP"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~arm ~sparc"
+SLOT="0"
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+
+DEPEND="${DEPEND}
+ apache2? ( >=net-www/apache-2.0.43-r1 )
+ !apache2? ( !<net-www/apache-1.3.26-r2 <net-www/apache-2 )"
+
+src_compile() {
+ #no readline on server SAPI
+ myconf="${myconf} --without-readline"
+
+ # Every Apache2 MPM EXCEPT prefork needs Zend Thread Safety
+ if [ "`use apache2`" ]; then
+ APACHE2_MPM="`apache2 -l |egrep 'worker|prechild|leader|threadpool|prefork'|xargs|cut -d. -f1`"
+ case "${APACHE2_MPM}" in
+ prefork) ;;
+ *) myconf="${myconf} --enable-experimental-zts" ;;
+ esac;
+ fi
+
+ # optional support for apache2
+ #&& myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ #|| myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+
+ #use apache2 \
+ has_version '>=net-www/apache-2' \
+ && myconf="${myconf} --with-apxs2=/usr/sbin/apxs2" \
+ || myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+
+
+ #php CGI stuff
+ #--enable-discard-path --enable-force-cgi-redirect
+
+ # No CLI in here
+ myconf="${myconf} --disable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+
+ cp php.ini-dist php.ini
+ insinto /etc/php4
+ doins php.ini
+
+ if [ "`use apache2`" ] ; then
+ dosym /usr/lib/apache2-extramodules /etc/php4/lib
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/70_mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache2/conf/php.ini
+ else
+ dosym /usr/lib/apache-extramodules /etc/php4/lib
+ exeinto /usr/lib/apache-extramodules
+ doexe .libs/libphp4.so
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_php.conf
+ dosym /etc/php4/php.ini /etc/apache/conf/php.ini
+ dosym /etc/php4/php.ini /etc/apache/conf/addon-modules/php.ini
+ fi
+}
+
+apache2msg() {
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PHP\""
+}
+
+pkg_postinst() {
+ einfo "To have Apache run php programs, please do the following:"
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ einfo "1. Execute the command:"
+ einfo " \"ebuild /var/db/pkg/dev-php/${PF}/${PF}.ebuild config\""
+ einfo "2. Edit /etc/conf.d/apache and add \"-D PHP\""
+ einfo "That will include the php mime types in your configuration"
+ einfo "automagically and setup Apache to load php when it starts."
+ fi
+}
+
+pkg_config() {
+ if [ "`use apache2`" ] ; then
+ apache2msg
+ else
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libphp4.so mod_php4.c php4_module \
+ before=perl define=PHP4 addconf=conf/addon-modules/mod_php.conf
+ :;
+ fi
+}