summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-17 16:12:41 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-17 16:12:41 +0000
commit7ce28c649693e3d5e1acb4609ba7e06f6da3b8d9 (patch)
tree665c8c51b155e5f749cc87012cfcf937717466cc /dev-php/phpgroupware
parentVersion bumped. Security one. (diff)
downloadhistorical-7ce28c649693e3d5e1acb4609ba7e06f6da3b8d9.tar.gz
historical-7ce28c649693e3d5e1acb4609ba7e06f6da3b8d9.tar.bz2
historical-7ce28c649693e3d5e1acb4609ba7e06f6da3b8d9.zip
Version bumped. Security one.
Diffstat (limited to 'dev-php/phpgroupware')
-rw-r--r--dev-php/phpgroupware/Manifest4
-rw-r--r--dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.0071
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.007.ebuild42
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-php/phpgroupware/Manifest b/dev-php/phpgroupware/Manifest
index 467c7d00362a..390557ebd035 100644
--- a/dev-php/phpgroupware/Manifest
+++ b/dev-php/phpgroupware/Manifest
@@ -1,5 +1,5 @@
-MD5 fa7d76e5a7e66c73c860b5163601b2e5 ChangeLog 1640
-MD5 5558230fa165cb252524f0b9f7a044aa phpgroupware-0.9.14.007.ebuild 1402
+MD5 c4a3ef01662d128d6d383e9cff360a2b ChangeLog 1797
+MD5 0afb7b0966a31c2a055ecf8529982033 phpgroupware-0.9.14.007.ebuild 1302
MD5 5558230fa165cb252524f0b9f7a044aa phpgroupware-0.9.14.006.ebuild 1402
MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
MD5 02797b628fc7108b8d474fad0bc92cae files/digest-phpgroupware-0.9.14.007 77
diff --git a/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.007 b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.007
new file mode 100644
index 000000000000..64d9e1c60916
--- /dev/null
+++ b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.007
@@ -0,0 +1 @@
+MD5 864ba1456d90f40aa4d3497d6075f29e phpgroupware-0.9.14.007.tar.bz2 6076046
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.007.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.007.ebuild
new file mode 100644
index 000000000000..f2b815e4b302
--- /dev/null
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.007.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.007.ebuild,v 1.1 2003/10/17 16:12:36 mholzer Exp $
+
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="intranet/groupware tool and application framework"
+HOMEPAGE="http://www.phpgroupware.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old phpGroupWare version first."
+ ewarn "phpGroupWare will be installed into ${HTTPD_ROOT}/phpgroupware"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_install() {
+ dodir ${HTTPD_ROOT}/${PN}
+ cd ${WORKDIR}
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} phpgroupware
+ dohtml ${PN}/doc/en_US/html/admin/*.html
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at /usr/share/doc/${PF}/html/x62.html#AEN134 "
+ einfo "to complete the install. You need to add MySQL users and configure phpGroupWare"
+}