summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-08-07 11:10:51 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-08-07 11:10:51 +0000
commiteaa8e8a1557d5b95fa8ecf76abae7a1036d9e202 (patch)
tree0d704eadbe628a28f33bf4078190d6ccfa4272e4 /dev-php/simpletest/simpletest-1.0.1.ebuild
parentAdd missing dep, bug #234026 (diff)
downloadhistorical-eaa8e8a1557d5b95fa8ecf76abae7a1036d9e202.tar.gz
historical-eaa8e8a1557d5b95fa8ecf76abae7a1036d9e202.tar.bz2
historical-eaa8e8a1557d5b95fa8ecf76abae7a1036d9e202.zip
version bump wrt bug 230932, thanks James Le Cuirot <chewi@aura-online.co.uk> [proxy commit for matthiassch], removing old
Package-Manager: portage-2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'dev-php/simpletest/simpletest-1.0.1.ebuild')
-rw-r--r--dev-php/simpletest/simpletest-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/simpletest/simpletest-1.0.1.ebuild b/dev-php/simpletest/simpletest-1.0.1.ebuild
new file mode 100644
index 000000000000..6a7f2c1730a2
--- /dev/null
+++ b/dev-php/simpletest/simpletest-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/simpletest/simpletest-1.0.1.ebuild,v 1.1 2008/08/07 11:10:51 hoffie Exp $
+
+inherit php-lib-r1 depend.php
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A PHP testing framework."
+HOMEPAGE="http://www.lastcraft.com/simple_test.php"
+SRC_URI="mirror://sourceforge/simpletest/${PN}_${PV/_/}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php [[:upper:]]*
+ rm -f [[:upper:]]*
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r docs/
+ rm -rf docs/
+
+ php-lib-r1_src_install . `find . -type f -print`
+}