summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-04 16:13:51 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-04 16:13:51 +0000
commit7fed0fb6f5c420132b784eaa22b88ad84802d9bb (patch)
treef98e58cc54b817c9dc925df8a03c927215d48840 /dev-php4/xdebug
parentInitial import (diff)
downloadhistorical-7fed0fb6f5c420132b784eaa22b88ad84802d9bb.tar.gz
historical-7fed0fb6f5c420132b784eaa22b88ad84802d9bb.tar.bz2
historical-7fed0fb6f5c420132b784eaa22b88ad84802d9bb.zip
Initial import for PHP4
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-php4/xdebug')
-rw-r--r--dev-php4/xdebug/ChangeLog7
-rw-r--r--dev-php4/xdebug/files/digest-xdebug-1.3.21
-rw-r--r--dev-php4/xdebug/metadata.xml5
-rw-r--r--dev-php4/xdebug/xdebug-1.3.2.ebuild25
4 files changed, 38 insertions, 0 deletions
diff --git a/dev-php4/xdebug/ChangeLog b/dev-php4/xdebug/ChangeLog
new file mode 100644
index 000000000000..f7f2d105c8a6
--- /dev/null
+++ b/dev-php4/xdebug/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-php4/xdebug
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/xdebug/ChangeLog,v 1.1 2005/09/04 16:13:51 stuart Exp $
+
+ 18 Aug 2005; <stuart@gentoo.org> ChangeLog:
+ Initial version; replaces older dev-php/* packages
+
diff --git a/dev-php4/xdebug/files/digest-xdebug-1.3.2 b/dev-php4/xdebug/files/digest-xdebug-1.3.2
new file mode 100644
index 000000000000..5c3dec6f3ea5
--- /dev/null
+++ b/dev-php4/xdebug/files/digest-xdebug-1.3.2
@@ -0,0 +1 @@
+MD5 bf76f41de570da77ab6db67d2c8cbffe xdebug-1.3.2.tgz 153629
diff --git a/dev-php4/xdebug/metadata.xml b/dev-php4/xdebug/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php4/xdebug/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php4/xdebug/xdebug-1.3.2.ebuild b/dev-php4/xdebug/xdebug-1.3.2.ebuild
new file mode 100644
index 000000000000..24222ddc13a5
--- /dev/null
+++ b/dev-php4/xdebug/xdebug-1.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/xdebug/xdebug-1.3.2.ebuild,v 1.1 2005/09/04 16:13:51 stuart Exp $
+
+PHP_EXT_ZENDEXT="yes"
+PHP_EXT_NAME="xdebug"
+
+inherit php-ext-source-r1
+
+IUSE=""
+DESCRIPTION="A PHP Debugging and Profiling extension."
+HOMEPAGE="http://www.xdebug.org/"
+SLOT="0"
+MY_P="${P/_/}"
+SRC_URI="http://www.xdebug.org/files/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="Xdebug"
+KEYWORDS="~ppc ~x86"
+
+need_php_by_category
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc NEWS README Changelog CREDITS LICENSE
+}