summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-07-22 02:10:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-07-22 02:10:07 +0000
commit25c76154b64cdd718ba69316d5431fbdb6d1b59d (patch)
treee7ad653e48792bd5466643f53718cc4126ce27f5 /dev-php
parentAbstract the MMcache directory, and correct 'fowner' -> 'fowners'. (diff)
downloadhistorical-25c76154b64cdd718ba69316d5431fbdb6d1b59d.tar.gz
historical-25c76154b64cdd718ba69316d5431fbdb6d1b59d.tar.bz2
historical-25c76154b64cdd718ba69316d5431fbdb6d1b59d.zip
Abstract the MMcache directory, and correct 'fowner' -> 'fowners'.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/turck-mmcache/Manifest4
-rw-r--r--dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild12
2 files changed, 9 insertions, 7 deletions
diff --git a/dev-php/turck-mmcache/Manifest b/dev-php/turck-mmcache/Manifest
index c77b9ba1c742..d956a1f2fa7a 100644
--- a/dev-php/turck-mmcache/Manifest
+++ b/dev-php/turck-mmcache/Manifest
@@ -1,3 +1,3 @@
-MD5 c53bd38f733ed8ec3bba764855cb23f9 turck-mmcache-2.3.19.ebuild 2511
-MD5 5752dc70593629cc9c9004674b82f128 ChangeLog 1019
+MD5 507626c0a21b6a1d20f47f769792e2de turck-mmcache-2.3.19.ebuild 2512
+MD5 93d9d389ba5af0818694e0249a88cd60 ChangeLog 1175
MD5 73606cb81a8ce6f7b1b300724ecf7307 files/digest-turck-mmcache-2.3.19 71
diff --git a/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild b/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild
index a6aef667629f..d2c0008875e1 100644
--- a/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild
+++ b/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild,v 1.4 2003/07/20 13:31:55 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/turck-mmcache/turck-mmcache-2.3.19.ebuild,v 1.5 2003/07/22 02:10:04 robbat2 Exp $
DESCRIPTION="Turck MMCache is a free open source PHP accelerator, optimizer, encoder and dynamic content cache for PHP. It increases performance of PHP scripts by caching them in compiled state, so that the overhead of compiling is almost completely eliminated. Also it uses some optimizations to speed up execution of PHP scripts. Turck MMCache typically reduces server load and increases the speed of your PHP code by 1-10 times."
SRC_URI="mirror://sourceforge/turck-mmcache/${P}.tar.gz"
@@ -14,6 +14,8 @@ KEYWORDS="~x86"
PHP_EXT_NAME="mmcache"
PHP_EXT_ZENDEXT="yes"
+[ -z "${MMCACHE_CACHEDIR}" ] && MMCACHE_CACHEDIR=/var/cache/mmcache
+
inherit php-ext
src_compile() {
@@ -33,9 +35,9 @@ src_install() {
# please file a bug in http://bugs.gentoo.org if this happens
# for you
- dodir /var/cache/mmcache
- fowner root.root /var/cache/mmcache
- fperms 1777 /var/cache/mmcache
+ keepdir ${MMCACHE_CACHEDIR}
+ fowners root.root ${MMCACHE_CACHEDIR}
+ fperms 1777 ${MMCACHE_CACHEDIR}
insinto /usr/share/${PN}
doins encoder.php mmcache.php mmcache.gif
@@ -47,7 +49,7 @@ pkg_postinst () {
php-ext_pkg_postinst
php-ext_addtoinifiles "mmcache.shm_size" '"16"'
- php-ext_addtoinifiles "mmcache.cache_dir" '"/var/cache/mmcache"'
+ php-ext_addtoinifiles "mmcache.cache_dir" "\"${MMCACHE_CACHEDIR}\""
php-ext_addtoinifiles "mmcache.enable" '"1"'
php-ext_addtoinifiles "mmcache.optimizer" '"1"'
php-ext_addtoinifiles "mmcache.check_mtime" '"1"'