summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-12 22:03:31 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-12 22:03:31 +0000
commite3086205e5db1551f3b5d11e03546bc248fb1d39 (patch)
treecb4f0075320540a922a69cc353cd5df1d83e480b /dev-php
parentInitial verison. (diff)
downloadhistorical-e3086205e5db1551f3b5d11e03546bc248fb1d39.tar.gz
historical-e3086205e5db1551f3b5d11e03546bc248fb1d39.tar.bz2
historical-e3086205e5db1551f3b5d11e03546bc248fb1d39.zip
Initial verison.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/groupoffice/Manifest3
-rw-r--r--dev-php/groupoffice/files/digest-groupoffice-1.912
-rw-r--r--dev-php/groupoffice/groupoffice-1.91.ebuild59
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-php/groupoffice/Manifest b/dev-php/groupoffice/Manifest
index e17d90c31036..59488e38c2f8 100644
--- a/dev-php/groupoffice/Manifest
+++ b/dev-php/groupoffice/Manifest
@@ -1,2 +1,3 @@
-MD5 5e10521145aba56ebdbea341d10a496e groupoffice-1.91.ebuild 1457
+MD5 dd1044b26cf1150d1f07ea056a8e83aa groupoffice-1.91.ebuild 1757
+MD5 6727da33f9675550f97c4e8d6a198e78 ChangeLog 349
MD5 935184d01c1f3a5138a2aae7b1f29520 files/digest-groupoffice-1.91 140
diff --git a/dev-php/groupoffice/files/digest-groupoffice-1.91 b/dev-php/groupoffice/files/digest-groupoffice-1.91
new file mode 100644
index 000000000000..34f70bf43bf0
--- /dev/null
+++ b/dev-php/groupoffice/files/digest-groupoffice-1.91
@@ -0,0 +1,2 @@
+MD5 bf0fc64839d71aba2c005c0c1c563ea6 groupoffice-1.91.tar.gz 789620
+MD5 8cb2d7e57d2497223ce032a74a40a6ff GO-theme-Crystal-1.9.tar.gz 285813
diff --git a/dev-php/groupoffice/groupoffice-1.91.ebuild b/dev-php/groupoffice/groupoffice-1.91.ebuild
new file mode 100644
index 000000000000..0bb96b4a79bb
--- /dev/null
+++ b/dev-php/groupoffice/groupoffice-1.91.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/groupoffice/groupoffice-1.91.ebuild,v 1.1 2003/10/12 22:03:25 mholzer Exp $
+
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="Group-Office is a powerfull modular Intranet application framework. It runs *nix using PHP and has several database support."
+HOMEPAGE="http://group-office.sourceforge.net/"
+SRC_URI="mirror://sourceforge/group-office/${P}.tar.gz
+ mirror://sourceforge/group-office/GO-theme-Crystal-1.9.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old ${PN} version first."
+ ewarn "${PN} be installed into ${HTTPD_ROOT}/${PN}"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack GO-theme-Crystal-1.9.tar.gz
+}
+
+src_install() {
+ dodir ${HTTPD_ROOT}/${PN}
+ cd ${WORKDIR}
+ mv ${P} ${PN}
+ mv ${WORKDIR}/crystal ${S}/themes
+ cd ${S}
+ dodoc CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
+ rm -rf CHANGELOG DEVELOPERS FAQ INSTALL RELEASE README.ldap TODO TRANSLATORS
+ cd ${WORKDIR}
+
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${PN}
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at /usr/share/doc/${PF}/INSTALL"
+ einfo "to complete the install. You need to add MySQL users"
+ einfo "and configure ${PN}"
+ einfo ""
+ einfo "Please make sure your php settings have"
+ einfo "register_globals = On"
+ einfo ""
+}