summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-25 17:03:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-25 17:03:36 +0000
commitb51aa10cecce2a4867c3b4c111ecb6756453a5bd (patch)
treec946b71cb3cf5f6234a06341943d9be10bf9f33d /dev-python/PyFoam
parentadd readline use flag; tidy (diff)
downloadhistorical-b51aa10cecce2a4867c3b4c111ecb6756453a5bd.tar.gz
historical-b51aa10cecce2a4867c3b4c111ecb6756453a5bd.tar.bz2
historical-b51aa10cecce2a4867c3b4c111ecb6756453a5bd.zip
Initial import from sunrise. Thanks to Oliver Borm for the ebuild and the sunrise people for massaging it into shape. Small python-2.6 fix as upstream tried to use with as a variable name.
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'dev-python/PyFoam')
-rw-r--r--dev-python/PyFoam/ChangeLog27
-rw-r--r--dev-python/PyFoam/Manifest5
-rw-r--r--dev-python/PyFoam/PyFoam-0.5.1.ebuild24
-rw-r--r--dev-python/PyFoam/files/PyFoam-py26.patch60
-rw-r--r--dev-python/PyFoam/metadata.xml5
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/PyFoam/ChangeLog b/dev-python/PyFoam/ChangeLog
new file mode 100644
index 000000000000..2a021893d0ea
--- /dev/null
+++ b/dev-python/PyFoam/ChangeLog
@@ -0,0 +1,27 @@
+# ChangeLog for dev-python/PyFoam
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyFoam/ChangeLog,v 1.1 2009/04/25 17:03:36 patrick Exp $
+
+*PyFoam-0.5.1 (25 Apr 2009)
+
+ 25 Apr 2009; Patrick Lauer <patrick@gentoo.org> +files/PyFoam-py26.patch,
+ +metadata.xml, +PyFoam-0.5.1.ebuild:
+ Initial import from sunrise. Thanks to Oliver Borm for the ebuild and the
+ sunrise people for massaging it into shape. Small python-2.6 fix as
+ upstream tried to use with as a variable name.
+
+ 13 Feb 2009; Oliver Borm (boroli) <oli.borm@web.de> -PyFoam-0.5.0.ebuild,
+ +PyFoam-0.5.1.ebuild:
+ Version bump.
+
+ 22 Sep 2008; Oliver Borm (boroli) <oli.borm@web.de> -PyFoam-0.4.3.ebuild,
+ +PyFoam-0.5.0.ebuild:
+ Version bump, added dependency
+
+ 24 Jun 2008; Oliver Borm (boroli) <oli.borm@web.de> PyFoam-0.4.3.ebuild:
+ Added dependencies, thanks to gentoofan23
+
+ 24 Jun 2008; Oliver Borm (boroli) <oli.borm@web.de> +PyFoam-0.4.3.ebuild,
+ +metadata.xml:
+ New ebuild for bug 229245
+
diff --git a/dev-python/PyFoam/Manifest b/dev-python/PyFoam/Manifest
new file mode 100644
index 000000000000..ae934bb1f3a1
--- /dev/null
+++ b/dev-python/PyFoam/Manifest
@@ -0,0 +1,5 @@
+AUX PyFoam-py26.patch 3074 RMD160 b291ebb91a41086757ceef8fd2c7eb21b56fc9a8 SHA1 920c5ee9e9557b7881462cd880eab98ebb5210d8 SHA256 679b6ccf35d39ae4af96c2359304747cee4b6fe67e8df01bed9a9937ec5195f5
+DIST PyFoam-0.5.1.tar.gz 2415566 RMD160 bb2630135098c5437b4700896ad48d0af3f8ee95 SHA1 a9b74edc9d4e2022868f8b0e34d4556a5faf2d7f SHA256 eb260af5fe3ff63e4cef8ebf86e0f22acd6395c497b45ded45fba753bf06d8c0
+EBUILD PyFoam-0.5.1.ebuild 694 RMD160 9ec2202bf791e3a8de625899b711943f79108545 SHA1 11b77dd2f326796a6c9fded5e415c5d87bc38183 SHA256 c8f0bdc14524f8b3fa0f4d583930f5d208e3d2f35e34f76460c94b9f9775f1c4
+MISC ChangeLog 1041 RMD160 db1c0f8ced4c775bae37534e76d12961e5f4ff4b SHA1 fd2f9aa1c583ae8d523909870d445095dfec1cd6 SHA256 da13788b5e0cf5ce586a6071a2df89295d493dc2a733f626bf383cd6584ac6e8
+MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/PyFoam/PyFoam-0.5.1.ebuild b/dev-python/PyFoam/PyFoam-0.5.1.ebuild
new file mode 100644
index 000000000000..f1e2587a351c
--- /dev/null
+++ b/dev-python/PyFoam/PyFoam-0.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyFoam/PyFoam-0.5.1.ebuild,v 1.1 2009/04/25 17:03:36 patrick Exp $
+
+EAPI="2"
+
+inherit eutils distutils
+
+DESCRIPTION="Tool to analyze and plot the residual files of OpenFOAM computations"
+HOMEPAGE="http://openfoamwiki.net/index.php/Contrib_PyFoam"
+SRC_URI="http://openfoamwiki.net/images/2/24/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot
+ || ( sci-libs/openfoam-meta sci-libs/openfoam sci-libs/openfoam-bin ) "
+
+src_prepare() {
+ epatch "${FILESDIR}/PyFoam-py26.patch"
+}
diff --git a/dev-python/PyFoam/files/PyFoam-py26.patch b/dev-python/PyFoam/files/PyFoam-py26.patch
new file mode 100644
index 000000000000..61d881b41ee0
--- /dev/null
+++ b/dev-python/PyFoam/files/PyFoam-py26.patch
@@ -0,0 +1,60 @@
+diff -Naur PyFoam-0.5.1-old/PyFoam/Basics/GnuplotTimelines.py PyFoam-0.5.1/PyFoam/Basics/GnuplotTimelines.py
+--- PyFoam-0.5.1-old/PyFoam/Basics/GnuplotTimelines.py 2009-04-25 16:42:38.000000000 +0000
++++ PyFoam-0.5.1/PyFoam/Basics/GnuplotTimelines.py 2009-04-25 16:59:05.000000000 +0000
+@@ -14,7 +14,7 @@
+ timelines,
+ persist=None,
+ raiseit=True,
+- with="lines",
++ style="lines",
+ alternateAxis=[],
+ forbidden=[],
+ start=None,
+@@ -26,7 +26,7 @@
+ @type timelines: TimeLineCollection
+ @param persist: Gnuplot window persistst after run
+ @param raiseit: Raise the window at every plot
+- @param with: how to plot the data (lines, points, steps)
++ @param style: how to plot the data (lines, points, steps)
+ @param alternateAxis: list with names that ought to appear on the alternate y-axis
+ @param forbidden: A list with strings. If one of those strings is found in a name, it is not plotted
+ @param start: First time that should be plotted. If undefined everything from the start is plotted
+@@ -74,7 +74,7 @@
+ self.set_string("terminal x11"+x11addition)
+
+ self.data=timelines
+- self.with=with
++ self.style=style
+
+ self.redo()
+
+@@ -97,7 +97,7 @@
+
+ self.itemlist=[]
+ for n in names:
+- it=Data(times,self.data.getValues(n),title=n,with=self.with)
++ it=Data(times,self.data.getValues(n),title=n,style=self.style)
+ if n in self.alternate:
+ it.set_option(axes="x1y2")
+
+diff -Naur PyFoam-0.5.1-old/PyFoam/Execution/GnuplotRunner.py PyFoam-0.5.1/PyFoam/Execution/GnuplotRunner.py
+--- PyFoam-0.5.1-old/PyFoam/Execution/GnuplotRunner.py 2009-04-25 16:42:38.000000000 +0000
++++ PyFoam-0.5.1/PyFoam/Execution/GnuplotRunner.py 2009-04-25 17:00:16.000000000 +0000
+@@ -83,7 +83,7 @@
+ if plotIterations:
+ self.plots["iter"]=GnuplotTimelines(self.getAnalyzer("Iterations").lines,
+ persist=persist,
+- with="steps",
++ style="steps",
+ raiseit=raiseit,
+ start=start,
+ end=end)
+@@ -115,7 +115,7 @@
+ if plotExecution:
+ self.plots["execution"]=GnuplotTimelines(self.getAnalyzer("Execution").lines,
+ persist=persist,
+- with="steps",
++ style="steps",
+ raiseit=raiseit,
+ start=start,
+ end=end)
diff --git a/dev-python/PyFoam/metadata.xml b/dev-python/PyFoam/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/PyFoam/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>