summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-08-01 20:12:17 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-08-01 20:12:17 +0000
commit5be898c068055bf48d6b1c9b9f5da8a208cf1f5b (patch)
tree8ce38b8a4d3a2bf6e63f3ba75130c0b3df3c3bc6 /dev-python/PyQt
parentre-added sip 2.4 (diff)
downloadhistorical-5be898c068055bf48d6b1c9b9f5da8a208cf1f5b.tar.gz
historical-5be898c068055bf48d6b1c9b9f5da8a208cf1f5b.tar.bz2
historical-5be898c068055bf48d6b1c9b9f5da8a208cf1f5b.zip
re-added 2.4
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/PyQt-2.4.ebuild31
-rw-r--r--dev-python/PyQt/files/digest-PyQt-2.41
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/PyQt/PyQt-2.4.ebuild b/dev-python/PyQt/PyQt-2.4.ebuild
new file mode 100644
index 000000000000..a95aba1fccd1
--- /dev/null
+++ b/dev-python/PyQt/PyQt-2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.9 2002/08/01 20:12:17 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
+SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
+HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/qt-2*
+ =dev-python/sip-2.4
+ virtual/python"
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc \
+ --with-qt-dir=/usr/qt/2
+ assert
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-doc || die
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-2.4 b/dev-python/PyQt/files/digest-PyQt-2.4
new file mode 100644
index 000000000000..ed0201648746
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-2.4
@@ -0,0 +1 @@
+MD5 fd0d89874f66f6190421839188aff02f PyQt-2.4.tar.gz 2553774