summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-01-05 18:17:39 +0000
committerMike Gilbert <floppym@gentoo.org>2013-01-05 18:17:39 +0000
commitff26af23fbff7cdfa49ca5bbc9b95925022c536d (patch)
tree1ec3af7f93c8671aeab64fabf7fc2365711cfc9f /dev-python/argh/argh-0.17.2.ebuild
parentAdd upstream patch to fix problems with unmounted network media, fixes bug 45... (diff)
downloadhistorical-ff26af23fbff7cdfa49ca5bbc9b95925022c536d.tar.gz
historical-ff26af23fbff7cdfa49ca5bbc9b95925022c536d.tar.bz2
historical-ff26af23fbff7cdfa49ca5bbc9b95925022c536d.zip
Fix UnicodeDecodeError in setup.py. Bug 448728 by flameeyes.
Package-Manager: portage-2.2.0_alpha149/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'dev-python/argh/argh-0.17.2.ebuild')
-rw-r--r--dev-python/argh/argh-0.17.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/argh/argh-0.17.2.ebuild b/dev-python/argh/argh-0.17.2.ebuild
index 74b470c9e0cb..23e2d9417c13 100644
--- a/dev-python/argh/argh-0.17.2.ebuild
+++ b/dev-python/argh/argh-0.17.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/argh/argh-0.17.2.ebuild,v 1.1 2012/11/29 08:43:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/argh/argh-0.17.2.ebuild,v 1.2 2013/01/05 18:17:36 floppym Exp $
EAPI=4
@@ -9,7 +9,7 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.5 2.5-jython"
PYTHON_MODNAME="argh"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="A simple argparse wrapper."
HOMEPAGE="http://packages.python.org/argh/"
@@ -21,3 +21,8 @@ LICENSE="LGPL-3"
RDEPEND=""
DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-setup.py.patch"
+ distutils_src_prepare
+}