summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-07-02 10:40:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-07-02 10:40:47 +0000
commit6fe3691f540329bb8334be79f483c1c4c949175d (patch)
tree0277f94969c823e4fa40705a858688ab561e982a /dev-python/astroid/astroid-1.3.2.ebuild
parentpycadf-0.8.0.ebuild; tidy & correction to deps: 1 missing dep for doc build, ... (diff)
downloadhistorical-6fe3691f540329bb8334be79f483c1c4c949175d.tar.gz
historical-6fe3691f540329bb8334be79f483c1c4c949175d.tar.bz2
historical-6fe3691f540329bb8334be79f483c1c4c949175d.zip
Remove old.
Package-Manager: portage-2.2.20/cvs/Linux x86_64
Diffstat (limited to 'dev-python/astroid/astroid-1.3.2.ebuild')
-rw-r--r--dev-python/astroid/astroid-1.3.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/astroid/astroid-1.3.2.ebuild b/dev-python/astroid/astroid-1.3.2.ebuild
deleted file mode 100644
index 1b90dfb9b9b1..000000000000
--- a/dev-python/astroid/astroid-1.3.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.3.2.ebuild,v 1.1 2014/12/10 07:51:39 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-RESTRICT="test" # False is not True ;)
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- test? ( ${RDEPEND}
- >=dev-python/pylint-1.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7) )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-# Restrict to test phase, required because suite fails horribly without it
-src_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build
-
- pushd build/lib > /dev/null
- PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
-}