summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-15 19:46:22 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-15 19:46:22 +0000
commitd195f6cccc1d1006e0d8f126e9319e801515abfc (patch)
tree4a88e10a8576dd2d26b5e4e0e6576eaab9edb679 /dev-python/contextlib2/contextlib2-0.4.0.ebuild
parentRaised alsa-lib dependency to -r1 because -r0 was reverted to without multili... (diff)
downloadhistorical-d195f6cccc1d1006e0d8f126e9319e801515abfc.tar.gz
historical-d195f6cccc1d1006e0d8f126e9319e801515abfc.tar.bz2
historical-d195f6cccc1d1006e0d8f126e9319e801515abfc.zip
Introduce contextlib2, a library providing backports and extensions to the contextlib module. It is needed for bedup.
Package-Manager: portage-2.2.0_alpha188/cvs/Linux x86_64 Manifest-Sign-Key: 0x9627F456F9DA7643!
Diffstat (limited to 'dev-python/contextlib2/contextlib2-0.4.0.ebuild')
-rw-r--r--dev-python/contextlib2/contextlib2-0.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/contextlib2/contextlib2-0.4.0.ebuild b/dev-python/contextlib2/contextlib2-0.4.0.ebuild
new file mode 100644
index 000000000000..4911fbc326cf
--- /dev/null
+++ b/dev-python/contextlib2/contextlib2-0.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/contextlib2/contextlib2-0.4.0.ebuild,v 1.1 2013/07/15 19:46:14 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backports and enhancements for the contextlib module"
+HOMEPAGE="https://pypi.python.org/pypi/contextlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" test_contextlib2.py || die "Tests fail for ${EPYTHON}"
+}