summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-17 13:42:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-17 13:42:53 +0000
commit9673badb7af54dde49f0c25a788c11df43c97a81 (patch)
tree74bc772ea8a85086990633b8f4ea403b460423e6 /dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild
parentVersion bump, bug #446174. (diff)
downloadhistorical-9673badb7af54dde49f0c25a788c11df43c97a81.tar.gz
historical-9673badb7af54dde49f0c25a788c11df43c97a81.tar.bz2
historical-9673badb7af54dde49f0c25a788c11df43c97a81.zip
Migrate to distutils-r1. Restrict tests because of the requirement for couchdb server, bug #327869.
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x42B9401D
Diffstat (limited to 'dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild')
-rw-r--r--dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild b/dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild
new file mode 100644
index 000000000000..f9d1d9a98de1
--- /dev/null
+++ b/dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/couchdb-python/couchdb-python-0.8-r1.ebuild,v 1.1 2013/02/17 13:42:51 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="CouchDB"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library for working with CouchDB"
+HOMEPAGE="http://code.google.com/p/couchdb-python/ http://pypi.python.org/pypi/CouchDB"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]
+ virtual/python-json[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+# Tests require connectivity to a couchdb server.
+# Re-enable when the ebuild is capable of starting a local couchdb
+# instance.
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}