summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-10-18 22:56:04 +0000
committerTim Harder <radhermit@gentoo.org>2013-10-18 22:56:04 +0000
commit5013b0e27a890ccb5a22264946630997708dfc0d (patch)
tree1784ed8c9b74041c6c07852a148c5751132e4a25 /dev-python/dulwich/dulwich-0.9.3.ebuild
parentAdd more keywords. (diff)
downloadhistorical-5013b0e27a890ccb5a22264946630997708dfc0d.tar.gz
historical-5013b0e27a890ccb5a22264946630997708dfc0d.tar.bz2
historical-5013b0e27a890ccb5a22264946630997708dfc0d.zip
Version bump, switch to pypi for SRC_URI.
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'dev-python/dulwich/dulwich-0.9.3.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.9.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/dulwich/dulwich-0.9.3.ebuild b/dev-python/dulwich/dulwich-0.9.3.ebuild
new file mode 100644
index 000000000000..bc62bccae65e
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.9.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.9.3.ebuild,v 1.1 2013/10/18 22:56:00 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ ln -s "${BUILD_DIR}"/lib/dulwich/*.so dulwich/ || die
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}