summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-10-10 15:47:19 +0000
committerFabian Groffen <grobian@gentoo.org>2009-10-10 15:47:19 +0000
commitda700328d713f4686b1c61c9da53335d1a1bdd35 (patch)
tree5867ba8cea16c95be271074542e5fef310377dd7 /dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild
parentsparc stable wrt #279638 (diff)
downloadhistorical-da700328d713f4686b1c61c9da53335d1a1bdd35.tar.gz
historical-da700328d713f4686b1c61c9da53335d1a1bdd35.tar.bz2
historical-da700328d713f4686b1c61c9da53335d1a1bdd35.zip
Merge from Prefix
Package-Manager: portage-2.2.00.14552-prefix/cvs/Darwin powerpc RepoMan-Options: --force
Diffstat (limited to 'dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild')
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild
index 5ad0aa9d4ba6..afb2c2f9aad4 100644
--- a/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild,v 1.9 2009/09/27 19:09:50 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.1.2.ebuild,v 1.10 2009/10/10 15:42:03 grobian Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -13,7 +13,7 @@ SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
LICENSE="eGenixPublic-1.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""
DEPEND=""
@@ -45,6 +45,7 @@ src_compile() {
}
src_install() {
+ [[ -z ${ED} ]] && local ED=${D}
distutils_src_install
dohtml -a html -r mx
insinto /usr/share/doc/${PF}
@@ -52,8 +53,8 @@ src_install() {
installation_of_headers() {
dodir "$(python_get_includedir)/mx"
- find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0 | while read -d $'\0' header; do
- mv -f "${header}" "${D}$(python_get_includedir)/mx"
+ find "${ED}$(python_get_sitedir)/mx" -type f -name "*.h" -print0 | while read -d $'\0' header; do
+ mv -f "${header}" "${ED}$(python_get_includedir)/mx"
done
}
python_execute_function --action-message 'Installation of headers with Python ${PYTHON_ABI}' installation_of_headers