summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 10:33:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 10:33:22 +0000
commit6b43e3ba6bf280120dc98a0492b4d441a89259f3 (patch)
tree4be340880663ee2198a3ed86707ebf68b8c5db24 /dev-python/etsdevtools
parentVersion bump, remove old, arm/ia64/sparc/x86 stable (diff)
downloadhistorical-6b43e3ba6bf280120dc98a0492b4d441a89259f3.tar.gz
historical-6b43e3ba6bf280120dc98a0492b4d441a89259f3.tar.bz2
historical-6b43e3ba6bf280120dc98a0492b4d441a89259f3.zip
Initial import
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'dev-python/etsdevtools')
-rw-r--r--dev-python/etsdevtools/ChangeLog10
-rw-r--r--dev-python/etsdevtools/etsdevtools-3.0.1.ebuild58
-rw-r--r--dev-python/etsdevtools/metadata.xml30
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/etsdevtools/ChangeLog b/dev-python/etsdevtools/ChangeLog
new file mode 100644
index 000000000000..e39f06093a2b
--- /dev/null
+++ b/dev-python/etsdevtools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/etsdevtools
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/etsdevtools/ChangeLog,v 1.1 2009/01/15 10:27:10 bicatali Exp $
+
+*etsdevtools-3.0.1 (15 Jan 2009)
+
+ 15 Jan 2009; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +etsdevtools-3.0.1.ebuild:
+ Initial import
+
diff --git a/dev-python/etsdevtools/etsdevtools-3.0.1.ebuild b/dev-python/etsdevtools/etsdevtools-3.0.1.ebuild
new file mode 100644
index 000000000000..e7157d113dbb
--- /dev/null
+++ b/dev-python/etsdevtools/etsdevtools-3.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/etsdevtools/etsdevtools-3.0.1.ebuild,v 1.1 2009/01/15 10:27:10 bicatali Exp $
+
+EAPI=2
+inherit distutils
+
+MY_PN="ETSDevTools"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Enthought Tool Suite to support Python development"
+HOMEPAGE="http://code.enthought.com/projects/ets_dev_tools.php"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+IUSE="doc examples test wxwindows"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND=">=dev-python/numpy-1.1
+ dev-python/docutils
+ dev-python/celementtree
+ dev-python/elementtree
+ dev-python/traitsgui
+ dev-python/nose
+ dev-python/pyro
+ dev-python/reportlab
+ dev-python/testoob
+ x11-libs/libXtst
+ wxwindows? ( dev-python/wxpython )"
+
+DEPEND="dev-python/setuptools
+ >=dev-python/numpy-1.1
+ x11-libs/libXtst
+ test? ( >=dev-python/nose-0.10.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ sed -i -e "/self.run_command('build_docs')/d" setup.py || die
+}
+
+src_test() {
+ PYTHONPATH=$(dir -d build/lib*) ${python} setup.py test || die "tests failed"
+}
+
+src_install() {
+ find "${S}" -name \*LICENSE.txt -delete
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r docs/*/*.pdf || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}
diff --git a/dev-python/etsdevtools/metadata.xml b/dev-python/etsdevtools/metadata.xml
new file mode 100644
index 000000000000..c89897249522
--- /dev/null
+++ b/dev-python/etsdevtools/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The ETSDevTools project from the Enthought Tool Suite includes a
+ set of packages that can be used during the development of a
+ software project, for understanding, debugging, testing, and
+ inspecting code:
+ * Enthought Developer Tool Suite (enthought.developer): A
+ collection of utilities, designed to ease the development and
+ debugging of Traits-based programs. They can be used as plug-ins
+ to your Envisage application while you are developing it, and then
+ removed when you are ready to release it.
+ * Endo: A Traits-aware tool for processing API documentation of
+ Python code. It extracts not only docstrings, but also plain
+ comments that immediately precede variable assignments (both
+ module-scope variables and class attributes).
+ * enthought.guitest: A collection of utilities for unit testing
+ user interfaces (translation of the Perl X11::GUITest and
+ Win32::GuiTest modules).
+ * enthought.testing: Scripts related to running unit tests, based
+ on testoob, and also allowing running test suites in separate
+ processes and aggregating the results.
+ * enthought.debug: A collection of debugging tools, not to be
+ included in production code. NOTE: These tools are functional, but
+ are not being developed or supported. They have been mainly
+ superceded by the tools in the Enthought Developer Tool Suite.
+ </longdescription>
+</pkgmetadata>