summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2013-05-18 19:55:59 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2013-05-18 19:55:59 +0000
commitabb24c76c1df53e6d5f714543812c4f6f65956aa (patch)
tree8f45dabaf66ca0900175a113a221d98bcb9ed951 /dev-python/falcon/falcon-0.1.6.ebuild
parentExplain people how to use latest vte.sh (needing to be sure latest version of... (diff)
downloadhistorical-abb24c76c1df53e6d5f714543812c4f6f65956aa.tar.gz
historical-abb24c76c1df53e6d5f714543812c4f6f65956aa.tar.bz2
historical-abb24c76c1df53e6d5f714543812c4f6f65956aa.zip
Version bump.
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64
Diffstat (limited to 'dev-python/falcon/falcon-0.1.6.ebuild')
-rw-r--r--dev-python/falcon/falcon-0.1.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/falcon/falcon-0.1.6.ebuild b/dev-python/falcon/falcon-0.1.6.ebuild
new file mode 100644
index 000000000000..4287f433bd82
--- /dev/null
+++ b/dev-python/falcon/falcon-0.1.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/falcon/falcon-0.1.6.ebuild,v 1.1 2013/05/18 19:55:42 rafaelmartins Exp $
+
+EAPI=5
+
+# Python 2.6 is supported, but depends on ordereddict, that isn't packaged for
+# Gentoo, and I don't think it is worth to maintain it. If someone needs it,
+# please let me know. PyPy also works, but needs testing.
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs."
+HOMEPAGE="http://falconframework.org/ https://pypi.python.org/pypi/falcon"
+SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cython test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ cython? (
+ dev-python/cython[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+src_prepare() {
+ if ! use cython; then
+ sed -i -e 's/if with_cython:/if False:/' setup.py \
+ || die 'sed failed.'
+ fi
+}