summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-17 08:59:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-17 08:59:45 +0000
commit3b68eaa3db02e9bf36e68b29ac44cd8f027af8fc (patch)
tree96e0748df78cb84ece67452856e82b25db20b52a /dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild
parentInitial import, ebuild by me (diff)
downloadhistorical-3b68eaa3db02e9bf36e68b29ac44cd8f027af8fc.tar.gz
historical-3b68eaa3db02e9bf36e68b29ac44cd8f027af8fc.tar.bz2
historical-3b68eaa3db02e9bf36e68b29ac44cd8f027af8fc.zip
Initial import, ebuild by me
Package-Manager: portage-2.2.0/cvs/Linux x86_64
Diffstat (limited to 'dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild')
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild
new file mode 100644
index 000000000000..a34811458608
--- /dev/null
+++ b/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild,v 1.1 2013/08/17 08:59:35 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Simple and extensible admin interface framework for Flask"
+HOMEPAGE="https://pypi.python.org/pypi/flask-mongoengine/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/mongoengine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}