summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-27 16:40:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-27 16:40:35 +0000
commit288a002e2125485633efdfbfed3e6483e90a590f (patch)
treed8f20fb2ac86faa236850d887727a9e151ce92f8 /dev-python/flask
parentVersion bump (bug #330077). (diff)
downloadhistorical-288a002e2125485633efdfbfed3e6483e90a590f.tar.gz
historical-288a002e2125485633efdfbfed3e6483e90a590f.tar.bz2
historical-288a002e2125485633efdfbfed3e6483e90a590f.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/flask-0.5.2.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/flask/flask-0.5.2.ebuild b/dev-python/flask/flask-0.5.2.ebuild
deleted file mode 100644
index a5ccf962d358..000000000000
--- a/dev-python/flask/flask-0.5.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.5.2.ebuild,v 1.1 2010/07/15 22:44:14 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="http://pypi.python.org/pypi/Flask"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/jinja-2.4
- dev-python/setuptools
- >=dev-python/werkzeug-0.6.1"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.6 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
-
- # Delete reference to nonexistent artwork/LICENSE file.
- sed -e "41,48d" -i docs/license.rst || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Generation of documentation failed"
- fi
-}
-
-src_test() {
- testing() {
- PYTHONPATH="." "$(PYTHON)" tests/flask_tests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- doins -r examples || die "Installation of examples failed"
- fi
-}