summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-17 18:29:56 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-17 18:29:56 +0000
commit2e5bbd86f56b4d460d8c43c15f10ca772081d422 (patch)
tree0f0e081625162c1a823bb74bf7763878837e6f76 /dev-python/foolscap
parentVersion bump. (diff)
downloadhistorical-2e5bbd86f56b4d460d8c43c15f10ca772081d422.tar.gz
historical-2e5bbd86f56b4d460d8c43c15f10ca772081d422.tar.bz2
historical-2e5bbd86f56b4d460d8c43c15f10ca772081d422.zip
Added dev-python/foolscap
Package-Manager: portage--svn/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'dev-python/foolscap')
-rw-r--r--dev-python/foolscap/ChangeLog10
-rw-r--r--dev-python/foolscap/Manifest14
-rw-r--r--dev-python/foolscap/foolscap-0.3.1.ebuild30
-rw-r--r--dev-python/foolscap/metadata.xml22
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/foolscap/ChangeLog b/dev-python/foolscap/ChangeLog
new file mode 100644
index 000000000000..da8b8574b363
--- /dev/null
+++ b/dev-python/foolscap/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/foolscap
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/foolscap/ChangeLog,v 1.1 2008/09/17 18:29:56 hawking Exp $
+
+*foolscap-0.3.1 (17 Sep 2008)
+
+ 17 Sep 2008; Ali Polatel <hawking@gentoo.org> +metadata.xml,
+ +foolscap-0.3.1.ebuild:
+ Initial ebuild.
+
diff --git a/dev-python/foolscap/Manifest b/dev-python/foolscap/Manifest
new file mode 100644
index 000000000000..bdbc896c07a6
--- /dev/null
+++ b/dev-python/foolscap/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST foolscap-0.3.1.tar.gz 436066 RMD160 00e90754b151fce32790f51bf2ef7a1911c48461 SHA1 0e43a84bef6a7037397d7ed2d32819a53063b540 SHA256 de08f26e59de823c8d5c3f41373cccd90043327cf00dcc0f1c3673c1b6deac87
+EBUILD foolscap-0.3.1.ebuild 778 RMD160 f08dda753f82786c37c714c0ebb152c28b6cd104 SHA1 94384def4f9b268b934653365e3170d2fa871527 SHA256 ab14e9025067288b824c7c5b2be15c4d040a31bc0d198549bcf8bd32fc630f78
+MISC ChangeLog 351 RMD160 a99c96703b1bd7a8233886d71a696be841990a78 SHA1 d45fb6dbb470a7f044b5a7fa175df72ad14794f1 SHA256 6bc53d5b6c0c0a0bacb5af4223f4d4db91e79b92f29a0b3c3507eda7d3566af0
+MISC metadata.xml 1119 RMD160 d0052abe0a21d815fd298b5666502623a3603d20 SHA1 93cd4077d540e5709d4ca2a6b165d855ea0d5425 SHA256 2aaa289cd63443ccf6929a6ea1c94df120f6800454f1b924c86f26ddce518be8
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkjRTK0ACgkQQU4yORhF8iAkCACfT4Vx77IQZfXrVBHRUslu5/RK
+4ukAnijFl5GJq+ejCXQugbO82bXsRxbN
+=H4HA
+-----END PGP SIGNATURE-----
diff --git a/dev-python/foolscap/foolscap-0.3.1.ebuild b/dev-python/foolscap/foolscap-0.3.1.ebuild
new file mode 100644
index 000000000000..896af07414e4
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/foolscap/foolscap-0.3.1.ebuild,v 1.1 2008/09/17 18:29:56 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="The next-generation RPC protocol, intended to replace Perspective Broker."
+HOMEPAGE="http://foolscap.lothar.com/trac"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=">=dev-python/twisted-2.4.0"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ dohtml -A py,tpl,xhtml -r doc/* || die "dohtml failed"
+ fi
+}
+
+src_test() {
+ PYTHONPATH=. trial ${PN} || die "tests failed"
+}
diff --git a/dev-python/foolscap/metadata.xml b/dev-python/foolscap/metadata.xml
new file mode 100644
index 000000000000..9c890460eaf7
--- /dev/null
+++ b/dev-python/foolscap/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+This is a ground-up rewrite of Perspective Broker, which itself is Twisted's
+native RPC/RMI protocol (Remote Procedure Call / Remote Method Invocation).
+If you have control of both ends of the wire, and are thus not constrained to
+use some other protocol like HTTP/XMLRPC/CORBA/etc, you might consider using
+Foolscap.
+
+Fundamentally, Foolscap allows you to make a python object in one process
+available to code in other processes, which means you can invoke its methods
+remotely. This includes a data serialization layer to convey the object
+graphs for the arguments and the eventual response, and an object reference
+system to keep track of which objects you are connecting to. It uses a
+capability-based security model, such that once you create a non-public
+object, it is only accessible to clients to whom you've given the
+(unguessable) FURL. You can of course publish world-visible objects that
+have well-known FURLs.
+</longdescription>
+</pkgmetadata>