summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-26 09:06:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-26 09:06:50 +0000
commit9c87268cd8335f4b32d33c1b7c01ad1c649f705e (patch)
tree35f871931122a5857f98db9d29e272cfbc4610a2 /dev-python/formencode
parentBump to 2.3.2, dep for bug #260168 (diff)
downloadhistorical-9c87268cd8335f4b32d33c1b7c01ad1c649f705e.tar.gz
historical-9c87268cd8335f4b32d33c1b7c01ad1c649f705e.tar.bz2
historical-9c87268cd8335f4b32d33c1b7c01ad1c649f705e.zip
Bump to 1.2.1, dep for bug #260168
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'dev-python/formencode')
-rw-r--r--dev-python/formencode/ChangeLog9
-rw-r--r--dev-python/formencode/formencode-1.2.1.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/formencode/ChangeLog b/dev-python/formencode/ChangeLog
index a89e4808cc07..f49326263765 100644
--- a/dev-python/formencode/ChangeLog
+++ b/dev-python/formencode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/formencode
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/ChangeLog,v 1.16 2008/04/22 13:44:38 chtekk Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/ChangeLog,v 1.17 2009/04/26 09:06:50 patrick Exp $
+
+*formencode-1.2.1 (26 Apr 2009)
+
+ 26 Apr 2009; Patrick Lauer <patrick@gentoo.org> +formencode-1.2.1.ebuild:
+ Bump to 1.2.1, dep for bug #260168
22 Apr 2008; Luca Longinotti <chtekk@gentoo.org> formencode-1.0.1.ebuild:
Empty RDEPEND.
diff --git a/dev-python/formencode/formencode-1.2.1.ebuild b/dev-python/formencode/formencode-1.2.1.ebuild
new file mode 100644
index 000000000000..c563c69967a2
--- /dev/null
+++ b/dev-python/formencode/formencode-1.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/formencode/formencode-1.2.1.ebuild,v 1.1 2009/04/26 09:06:50 patrick Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation and conversion package."
+HOMEPAGE="http://formencode.org/"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use doc ; then
+ cd "${S}"
+ dodoc docs/*.txt
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}