summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-06-18 06:25:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-06-18 06:25:37 +0000
commit458704d241a623ce13cfbf16041a9ba0d8e3ef84 (patch)
tree0daa03445453d7d018ecb106c30a85c73ca3b617 /dev-python/futures/futures-3.0.3.ebuild
parentVersion bump, use github repo and tarball. (diff)
downloadhistorical-458704d241a623ce13cfbf16041a9ba0d8e3ef84.tar.gz
historical-458704d241a623ce13cfbf16041a9ba0d8e3ef84.tar.bz2
historical-458704d241a623ce13cfbf16041a9ba0d8e3ef84.zip
Bump
Package-Manager: portage-2.2.20/cvs/Linux x86_64
Diffstat (limited to 'dev-python/futures/futures-3.0.3.ebuild')
-rw-r--r--dev-python/futures/futures-3.0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/futures/futures-3.0.3.ebuild b/dev-python/futures/futures-3.0.3.ebuild
new file mode 100644
index 000000000000..aaffc03189b5
--- /dev/null
+++ b/dev-python/futures/futures-3.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/futures/futures-3.0.3.ebuild,v 1.1 2015/06/18 06:25:27 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+DESCRIPTION="Backport of the concurrent.futures package from Python 3.2"
+HOMEPAGE="http://code.google.com/p/pythonfutures http://pypi.python.org/pypi/futures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # tests that fail under pypy
+ # http://code.google.com/p/pythonfutures/issues/detail?id=27
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_del_shutdown:_&:g' \
+ -e 's:test_repr:_&:' -i test_futures.py || die
+ fi
+ "${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}