summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-30 07:44:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-30 07:44:44 +0000
commit71c79e4586904d2a61782b7aa530be40b1402fe1 (patch)
treeac25fe42e85642cc84c79dc6595d493ce393c29e /dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild
parentMissed one more patch, bug #264564, fix for CVE-2009-0115. (diff)
downloadhistorical-71c79e4586904d2a61782b7aa530be40b1402fe1.tar.gz
historical-71c79e4586904d2a61782b7aa530be40b1402fe1.tar.bz2
historical-71c79e4586904d2a61782b7aa530be40b1402fe1.zip
Version bump, fix compilation with gdl-2.28, bug #290522. Remove built_with_use since it is useless with corresponding gdl versions, bug #289028.
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild')
-rw-r--r--dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild b/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild
new file mode 100644
index 000000000000..49bc02e1bff1
--- /dev/null
+++ b/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild,v 1.1 2009/10/30 07:44:43 eva Exp $
+
+G_PY_PN="gnome-python-extras"
+
+inherit gnome-python-common
+
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
+ mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
+
+DESCRIPTION="Python bindings for GDL"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/gdl-2.28.0"
+DEPEND="${RDEPEND}"
+
+EXAMPLES="examples/gdl/*"
+
+src_unpack() {
+ gnome-python-common_src_unpack
+
+ epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
+ eautoreconf
+
+ # Fix build failure with gdl-2.24
+ epatch "${FILESDIR}/${P}-gdlicons.patch"
+
+ # Fix build failure with gdl-2.28
+ epatch "${FILESDIR}/${P}-gdlapi-removal.patch"
+}