summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
commit1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae (patch)
treee5858b1bc23fa91ef29bbd90813bf2a028bdb3f9 /dev-python/gdl-python
parentsparc stable (bug 351487) (diff)
downloadhistorical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.tar.gz
historical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.tar.bz2
historical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.zip
Add missing eclass variables for proper python-updater behavior, bug #344833. Clean up old revision.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gdl-python')
-rw-r--r--dev-python/gdl-python/ChangeLog8
-rw-r--r--dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch15
-rw-r--r--dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild36
-rw-r--r--dev-python/gdl-python/gdl-python-2.25.3.ebuild6
4 files changed, 12 insertions, 53 deletions
diff --git a/dev-python/gdl-python/ChangeLog b/dev-python/gdl-python/ChangeLog
index 0675401c9384..835e375e0cf1 100644
--- a/dev-python/gdl-python/ChangeLog
+++ b/dev-python/gdl-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gdl-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/ChangeLog,v 1.35 2011/01/30 18:11:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/ChangeLog,v 1.36 2011/02/26 13:26:01 eva Exp $
+
+ 26 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ -gdl-python-2.19.1-r2.ebuild, -files/gdl-python-2.19.1-gdlicons.patch,
+ gdl-python-2.25.3.ebuild:
+ Add missing eclass variables for proper python-updater behavior, bug #344833.
+ Clean up old revision.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> gdl-python-2.25.3.ebuild:
alpha/ia64/sparc stable wrt #348987
diff --git a/dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch b/dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch
deleted file mode 100644
index 6ef9680be994..000000000000
--- a/dev-python/gdl-python/files/gdl-python-2.19.1-gdlicons.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Debian #500767
-GNOME #553911
-
-Index: b/gdl/gdl.override
-===================================================================
---- a/gdl/gdl.override 2008-10-01 11:16:02.455827766 +0200
-+++ b/gdl/gdl.override 2008-10-01 11:16:17.847329409 +0200
-@@ -6,7 +6,6 @@ headers
- #include <pygtk/pygtk.h>
- #include <gdl/gdl-dock.h>
- #include <gdl/libgdltypebuiltins.h>
--#include <gdl/gdl-icons.h>
- #ifndef HAVE_GDL_0_7
- # include <gdl/gdl-dock-bar.h>
- #endif
diff --git a/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild b/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild
deleted file mode 100644
index b34d77ca2cf8..000000000000
--- a/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.19.1-r2.ebuild,v 1.7 2010/07/09 10:41:39 ssuominen Exp $
-
-EAPI="2"
-G_PY_PN="gnome-python-extras"
-
-inherit gnome-python-common
-
-PVP="$(get_version_component_range 1-2)"
-SRC_URI="mirror://gnome/sources/${G_PY_PN}/${PVP}/${G_PY_PN}-${PV}.tar.bz2
- mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
-
-DESCRIPTION="Python bindings for GDL"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-RDEPEND=">=dev-libs/gdl-2.28"
-DEPEND="${RDEPEND}"
-
-EXAMPLES="examples/gdl/*"
-
-src_prepare() {
- epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
- eautoreconf
-
- # Fix build failure with gdl-2.24
- epatch "${FILESDIR}/${P}-gdlicons.patch"
-
- # Fix build failure with gdl-2.28
- epatch "${FILESDIR}/${P}-gdlapi-removal.patch"
-
- gnome-python-common_src_prepare
-}
diff --git a/dev-python/gdl-python/gdl-python-2.25.3.ebuild b/dev-python/gdl-python/gdl-python-2.25.3.ebuild
index 7a2d880e4c42..0c6f4aa97dcc 100644
--- a/dev-python/gdl-python/gdl-python-2.25.3.ebuild
+++ b/dev-python/gdl-python/gdl-python-2.25.3.ebuild
@@ -1,10 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.25.3.ebuild,v 1.7 2011/01/30 18:11:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdl-python/gdl-python-2.25.3.ebuild,v 1.8 2011/02/26 13:26:01 eva Exp $
EAPI="2"
G_PY_PN="gnome-python-extras"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit gnome-python-common
PVP="$(get_version_component_range 1-2)"