summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2011-08-27 14:24:18 +0000
committerMagnus Granberg <zorry@gentoo.org>2011-08-27 14:24:18 +0000
commitb983acd20cf2fa158f955fead869cde560b7b808 (patch)
tree1b4b7a4f662f56f1976815437c9cc20bce471114 /dev-python/git-python
parentAdd grub2 kcm module for in-kde configuration. (diff)
downloadhistorical-b983acd20cf2fa158f955fead869cde560b7b808.tar.gz
historical-b983acd20cf2fa158f955fead869cde560b7b808.tar.bz2
historical-b983acd20cf2fa158f955fead869cde560b7b808.zip
Add newer build of git-python
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/ChangeLog9
-rw-r--r--dev-python/git-python/Manifest4
-rw-r--r--dev-python/git-python/git-python-0.3.2_rc1.ebuild31
3 files changed, 41 insertions, 3 deletions
diff --git a/dev-python/git-python/ChangeLog b/dev-python/git-python/ChangeLog
index ee57ce47fe6d..fd707c744d69 100644
--- a/dev-python/git-python/ChangeLog
+++ b/dev-python/git-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/git-python
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.6 2010/07/15 17:16:50 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/ChangeLog,v 1.7 2011/08/27 14:24:18 zorry Exp $
+
+*git-python-0.3.2_rc1 (27 Aug 2011)
+
+ 27 Aug 2011; Magnus Granberg <zorry@gentoo.org> +git-python-0.3.2_rc1.ebuild:
+ Newer version of git-python
15 Jul 2010; Justin Lecher <jlec@gentoo.org> git-python-0.1.7.ebuild:
Keyworded for *-linux prefix, tested by me
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
index b222b1ef6017..fc17716c01f6 100644
--- a/dev-python/git-python/Manifest
+++ b/dev-python/git-python/Manifest
@@ -1,4 +1,6 @@
DIST GitPython-0.1.7.tar.gz 18087 RMD160 5733cd63b86bb69130cfc634835b5fc7c8a9182b SHA1 bdd93f4855420815724ca847a61e913119ae418e SHA256 03754bc7b256397c1b646e5048e2291590f5080171adb8b00f4e2d7384c76eee
+DIST GitPython-0.3.2.RC1.tar.gz 313486 RMD160 75488dcfe0be35066cd39eb63f909f999f17cdda SHA1 b9f43c91452f3fe7e105ac54ce878ff20ea44f44 SHA256 fd6786684a0d0dd7ebb961da754e3312fafe0c8e88f55ceb09858aa0af6094e0
EBUILD git-python-0.1.7.ebuild 786 RMD160 d73459d158ef1dc31555726150c92176d829c6a8 SHA1 d86380906b83fd7c972fba089b455d5596ef4b27 SHA256 5a60f62e45cfc5adb06d921622c4c6898859e9eb2c3c32614586ebb2b0e4fef0
-MISC ChangeLog 1031 RMD160 b04c9879210a57e5ffd41d317d02f48da6cdb8be SHA1 9a8677c4da3d60a99cf84ac182aeec4d990f356b SHA256 69621d8d3b5c852f6ada67f29f3c626d89f223b20b1d3f380017ecf8a449e3d3
+EBUILD git-python-0.3.2_rc1.ebuild 810 RMD160 703249930a37a2d23c8a8d75716d396e46e1bf62 SHA1 259895ea30e193154dccbff97b75e1fc364c514d SHA256 e2ebf615424b08c1f768665a4d57a74376e83b88ab2ec08f120936af5de00998
+MISC ChangeLog 1180 RMD160 9751ea20f37cf23ffbcb39d1ca2c141a2cd168d6 SHA1 81e976577036d84a8bfeea8336a2824f54642eb8 SHA256 49597c08a1e97abaf92c7e32e3771bafe5628f3794c8334a5eaf056ca84bc0a6
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/git-python/git-python-0.3.2_rc1.ebuild b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
new file mode 100644
index 000000000000..5bfd7a004c98
--- /dev/null
+++ b/dev-python/git-python/git-python-0.3.2_rc1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/git-python/git-python-0.3.2_rc1.ebuild,v 1.1 2011/08/27 14:24:18 zorry Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="GitPython"
+MY_PV=${PV/_rc/.RC}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="GitPython is a python library used to interact with Git repositories."
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="git"