summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-05-10 21:55:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-05-10 21:55:16 +0000
commitaaab261f16b5c16663e5266f064e1dce904f6fb6 (patch)
tree313250526fc47a6da6d08e2d3283712fb22429e8 /dev-python/gnome-applets-python
parentAdd mask for the haskell platform (testing). (diff)
downloadhistorical-aaab261f16b5c16663e5266f064e1dce904f6fb6.tar.gz
historical-aaab261f16b5c16663e5266f064e1dce904f6fb6.tar.bz2
historical-aaab261f16b5c16663e5266f064e1dce904f6fb6.zip
New version for GNOME 2.26. Clean up old revisions.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-python/gnome-applets-python')
-rw-r--r--dev-python/gnome-applets-python/ChangeLog10
-rw-r--r--dev-python/gnome-applets-python/files/gnome-applets-python-2.26.0-session-mgmt.patch28
-rw-r--r--dev-python/gnome-applets-python/gnome-applets-python-2.22.0.ebuild31
-rw-r--r--dev-python/gnome-applets-python/gnome-applets-python-2.26.0.ebuild (renamed from dev-python/gnome-applets-python/gnome-applets-python-2.24.0.ebuild)14
4 files changed, 48 insertions, 35 deletions
diff --git a/dev-python/gnome-applets-python/ChangeLog b/dev-python/gnome-applets-python/ChangeLog
index 193468008b45..98db25afc2d8 100644
--- a/dev-python/gnome-applets-python/ChangeLog
+++ b/dev-python/gnome-applets-python/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/gnome-applets-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-applets-python/ChangeLog,v 1.16 2009/04/28 11:45:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-applets-python/ChangeLog,v 1.17 2009/05/10 21:40:01 eva Exp $
+
+*gnome-applets-python-2.26.0 (10 May 2009)
+
+ 10 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -gnome-applets-python-2.22.0.ebuild, -gnome-applets-python-2.24.0.ebuild,
+ +gnome-applets-python-2.26.0.ebuild,
+ +files/gnome-applets-python-2.26.0-session-mgmt.patch:
+ New version for GNOME 2.26. Clean up old revisions.
28 Apr 2009; Raúl Porcel <armin76@gentoo.org>
gnome-applets-python-2.24.1.ebuild:
diff --git a/dev-python/gnome-applets-python/files/gnome-applets-python-2.26.0-session-mgmt.patch b/dev-python/gnome-applets-python/files/gnome-applets-python-2.26.0-session-mgmt.patch
new file mode 100644
index 000000000000..6d6646019464
--- /dev/null
+++ b/dev-python/gnome-applets-python/files/gnome-applets-python-2.26.0-session-mgmt.patch
@@ -0,0 +1,28 @@
+---
+ Add missing GNOME_CLIENT_PARAM_SM_CONNECT, FALSE in gnomeapplet module. Closes #579390.
+
+ gnomeapplet/applet.override | 1 +
+ gnomeapplet/applet.override | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/gnomeapplet/applet.override b/gnomeapplet/applet.override
+index 809da77..a203097 100644
+--- a/gnomeapplet/applet.override
++++ b/gnomeapplet/applet.override
+@@ -5,7 +5,7 @@ headers
+ #include <panel-applet.h>
+ #include <bonobo/bonobo-ui-util.h>
+ #include <libgnome/gnome-program.h>
+-#include <libgnomeui/gnome-ui-init.h>
++#include <libgnomeui/libgnomeui.h>
+
+ #define NO_IMPORT_PYGOBJECT
+ #include "pygobject.h"
+@@ -102,6 +102,7 @@ _wrap_panel__applet_bonobo_factory (PyGObject * self,
+ LIBGNOMEUI_MODULE,
+ argc, argv,
+ GNOME_PARAM_NONE,
++ GNOME_CLIENT_PARAM_SM_CONNECT, FALSE,
+ NULL);
+
+ pyg_begin_allow_threads;
diff --git a/dev-python/gnome-applets-python/gnome-applets-python-2.22.0.ebuild b/dev-python/gnome-applets-python/gnome-applets-python-2.22.0.ebuild
deleted file mode 100644
index cd9d3b2df021..000000000000
--- a/dev-python/gnome-applets-python/gnome-applets-python-2.22.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-applets-python/gnome-applets-python-2.22.0.ebuild,v 1.7 2009/03/27 22:00:21 jer Exp $
-
-G_PY_PN="gnome-python-desktop"
-G_PY_BINDINGS="applet"
-
-inherit gnome-python-common
-
-DESCRIPTION="Python bindings for writing GNOME applets"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
-IUSE="examples"
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/${G_PY_PN}-${PV}-split.patch.gz"
-
-RDEPEND=">=gnome-base/gnome-panel-2.13.4
- >=dev-python/libbonobo-python-2.22.1
- !<dev-python/gnome-python-desktop-2.22.0-r10"
-DEPEND="${RDEPEND}"
-
-EXAMPLES="examples/applet/*"
-
-src_unpack() {
- gnome-python-common_src_unpack
- cd "${S}"
- epatch "${WORKDIR}/${G_PY_PN}-${PV}-split.patch"
- eautoreconf
-}
diff --git a/dev-python/gnome-applets-python/gnome-applets-python-2.24.0.ebuild b/dev-python/gnome-applets-python/gnome-applets-python-2.26.0.ebuild
index c859de45ef21..08a1c4fd8ba1 100644
--- a/dev-python/gnome-applets-python/gnome-applets-python-2.24.0.ebuild
+++ b/dev-python/gnome-applets-python/gnome-applets-python-2.26.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-applets-python/gnome-applets-python-2.24.0.ebuild,v 1.2 2008/10/27 22:48:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-applets-python/gnome-applets-python-2.26.0.ebuild,v 1.1 2009/05/10 21:40:01 eva Exp $
G_PY_PN="gnome-python-desktop"
G_PY_BINDINGS="applet"
@@ -14,8 +14,16 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="examples"
RDEPEND=">=gnome-base/gnome-panel-2.13.4
- >=dev-python/libbonobo-python-2.22.1
+ >=dev-python/libbonobo-python-2.22.0
!<dev-python/gnome-python-desktop-2.22.0-r10"
DEPEND="${RDEPEND}"
EXAMPLES="examples/applet/*"
+
+src_unpack() {
+ gnome-python-common_src_unpack
+
+ # Fix session management of python applets, upstream bug #579390.
+ epatch "${FILESDIR}/${P}-session-mgmt.patch"
+}
+