summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-04 01:18:54 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-04 01:18:54 +0000
commitb90e18b0b7b5d6c8b6931dff9cd6d20e6869aeac (patch)
treea1aef022c6f68cf63c6ae580385ff4908a438edb /dev-python/graph-tool/graph-tool-9999.ebuild
parentInitial import, ebuild by me. (diff)
downloadhistorical-b90e18b0b7b5d6c8b6931dff9cd6d20e6869aeac.tar.gz
historical-b90e18b0b7b5d6c8b6931dff9cd6d20e6869aeac.tar.bz2
historical-b90e18b0b7b5d6c8b6931dff9cd6d20e6869aeac.zip
Initial import, ebuild by me.
Package-Manager: portage-2.2.0_alpha149/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'dev-python/graph-tool/graph-tool-9999.ebuild')
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
new file mode 100644
index 000000000000..a4f686b3a5fa
--- /dev/null
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.1 2013/01/04 01:18:49 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_1,3_2,3_3} )
+
+inherit eutils toolchain-funcs python-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.skewed.de/graph-tool"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="http://downloads.skewed.de/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
+HOMEPAGE="http://graph-tool.skewed.de/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+cairo openmp"
+
+CDEPEND=">=dev-libs/boost-1.46.0[python]
+ dev-libs/expat
+ dev-python/numpy
+ sci-libs/scipy
+ sci-mathematics/cgal
+ cairo? (
+ dev-cpp/cairomm
+ dev-python/pycairo
+ )"
+RDEPEND="${CDEPEND}
+ dev-python/matplotlib
+ media-gfx/graphviz[python]"
+DEPEND="${CDEPEND}
+ dev-cpp/sparsehash
+ virtual/pkgconfig"
+
+# most machines don't have enough ram for parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ >py-compile
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir \
+ econf \
+ --disable-static \
+ --disable-optimization \
+ $(use_enable openmp) \
+ $(use_enable cairo)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ prune_libtool_files --modules
+
+ # remove unwanted extra docs
+ rm -r "${ED}"/usr/usr || die
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null
+ "$@"
+ popd > /dev/null
+}