summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-23 16:35:03 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-23 16:35:03 +0000
commit2255c367ecb7b99bdf2710495bc5b941f2131595 (patch)
tree2e62a499741d41e0f169e9ae4705b96b61633c62 /dev-python/hiredis/hiredis-0.1.1-r1.ebuild
parentDon't die in testing function; we should let virtualmake clean up after itself. (diff)
downloadhistorical-2255c367ecb7b99bdf2710495bc5b941f2131595.tar.gz
historical-2255c367ecb7b99bdf2710495bc5b941f2131595.tar.bz2
historical-2255c367ecb7b99bdf2710495bc5b941f2131595.zip
revbump; migrate -> distutils-r1 without the patch
Package-Manager: portage-2.1.11.63/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/hiredis/hiredis-0.1.1-r1.ebuild')
-rw-r--r--dev-python/hiredis/hiredis-0.1.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/hiredis/hiredis-0.1.1-r1.ebuild b/dev-python/hiredis/hiredis-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..0560c4f93e59
--- /dev/null
+++ b/dev-python/hiredis/hiredis-0.1.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hiredis/hiredis-0.1.1-r1.ebuild,v 1.1 2013/06/23 16:34:33 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/pietern/hiredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/hiredis"
+RDEPEND="${DEPEND}"
+
+# This breaks build under distutils-r1
+#PATCHES=( "${FILESDIR}"/${P}-system-libs.patch )