summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2004-12-20 21:52:00 +0000
committerIan Leitch <port001@gentoo.org>2004-12-20 21:52:00 +0000
commit6aa0f576aa0c57fc9c5efb6a87a21f9ce20399c9 (patch)
treec7128d7ff3f24c0247b36b75449967b3e52e981d /dev-python/jonpy/jonpy-0.06.ebuild
parentInitial commit, closes bug #72378. (diff)
downloadhistorical-6aa0f576aa0c57fc9c5efb6a87a21f9ce20399c9.tar.gz
historical-6aa0f576aa0c57fc9c5efb6a87a21f9ce20399c9.tar.bz2
historical-6aa0f576aa0c57fc9c5efb6a87a21f9ce20399c9.zip
Initial commit
Diffstat (limited to 'dev-python/jonpy/jonpy-0.06.ebuild')
-rw-r--r--dev-python/jonpy/jonpy-0.06.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jonpy/jonpy-0.06.ebuild b/dev-python/jonpy/jonpy-0.06.ebuild
new file mode 100644
index 000000000000..216f37a36a46
--- /dev/null
+++ b/dev-python/jonpy/jonpy-0.06.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jonpy/jonpy-0.06.ebuild,v 1.1 2004/12/20 21:52:00 port001 Exp $
+
+inherit distutils
+
+IUSE=""
+
+HOMEPAGE="http://jonpy.sourceforge.net/"
+DESCRIPTION="Powerful multi-threaded object-oriented CGI/FastCGI/mod_python/html-templating facilities"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-lang/python-2.2"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils_src_install
+
+ dodir /usr/share/${P}/wt-examples
+ insinto /usr/share/${P}/wt-examples
+ doins ${S}/example/printenv.html ${S}/example/wt/printenv.html.py
+ dodir /usr/share/${P}/wt-examples/cgi-bin
+ insinto /usr/share/${P}/wt-examples/cgi-bin
+ doins ${S}/example/cgi-bin/wt.py
+
+ dodir /usr/share/doc/${P}/html/
+ insinto /usr/share/doc/${P}/html
+ for file in `ls ${S}/doc/`; do
+ doins ${S}/doc/${file}
+ done
+
+ dodoc LICENCE README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Examples for the 'wt' module have been installed in /usr/share/${P}/wt-examples"
+ echo
+}