summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2006-01-06 21:07:10 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2006-01-06 21:07:10 +0000
commit065018282a14b191fd5c38671448b82593c99bb7 (patch)
tree242647bbfdee1166372973a711039a56a10352b3 /dev-python/kid/kid-0.8.ebuild
parentNew ebuild thanks to Martti Rannanjärvi <mrannanj@iki.fi>, Russell Smith <mr... (diff)
downloadhistorical-065018282a14b191fd5c38671448b82593c99bb7.tar.gz
historical-065018282a14b191fd5c38671448b82593c99bb7.tar.bz2
historical-065018282a14b191fd5c38671448b82593c99bb7.zip
Version bump, updated patch, fixed typo (bug #117549). Fixed to install html docs and examples.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-python/kid/kid-0.8.ebuild')
-rw-r--r--dev-python/kid/kid-0.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/kid/kid-0.8.ebuild b/dev-python/kid/kid-0.8.ebuild
new file mode 100644
index 000000000000..cfa9f5bb329e
--- /dev/null
+++ b/dev-python/kid/kid-0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.8.ebuild,v 1.1 2006/01/06 21:07:10 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A simple and Pythonic XML template language"
+SRC_URI="http://kid.lesscode.org/dist/${PV}/${P}.tar.gz"
+HOMEPAGE="http://kid.lesscode.org/"
+
+KEYWORDS="~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=dev-python/elementtree-1.2.6"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die "Failed to unpack ${A}"
+ #Use distutils instead of egg
+ epatch ${FILESDIR}/${P}-ezsetup-gentoo.patch
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r doc/html/*
+ cp -r examples ${D}/usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ einfo "Installing dev-python/celementtree may enhance performance."
+}
+