summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 21:54:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 21:54:08 +0000
commit6e6e4d5f3ccb9ebd40bb3fe919d063c337ea38c9 (patch)
tree4f77d83c4d339e5c5294782802a2a70eab0a3723 /dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild
parentFix dependencies. (diff)
downloadhistorical-6e6e4d5f3ccb9ebd40bb3fe919d063c337ea38c9.tar.gz
historical-6e6e4d5f3ccb9ebd40bb3fe919d063c337ea38c9.tar.bz2
historical-6e6e4d5f3ccb9ebd40bb3fe919d063c337ea38c9.zip
Set SUPPORT_PYTHON_ABIS (bug #344729). Avoid breaking strict-aliasing rules.
Package-Manager: portage-2.2.0_alpha11_p6/cvs/Linux x86_64
Diffstat (limited to 'dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild')
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild
index e8cf6ab06e20..8dc5c85dec3e 100644
--- a/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild
@@ -1,15 +1,23 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild,v 1.2 2009/04/12 20:51:11 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libasyncns-python/libasyncns-python-0.7.1.ebuild,v 1.3 2011/01/01 21:54:08 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit distutils
DESCRIPTION="Python bindings for libasyncns."
HOMEPAGE="https://launchpad.net/libasyncns-python/"
SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+
DEPEND=">=net-libs/libasyncns-0.4"
RDEPEND="${DEPEND}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")