summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2002-12-17 07:45:56 +0000
committerTroy Dack <tad@gentoo.org>2002-12-17 07:45:56 +0000
commit57b35f4f501108bcf87598faf60415dbfba1d0cb (patch)
tree2d5cc92c80d7c45547707ce699eb44fc67169bc3 /dev-python/medusa/medusa-0.5.2.ebuild
parentnew skins for mplayer (diff)
downloadhistorical-57b35f4f501108bcf87598faf60415dbfba1d0cb.tar.gz
historical-57b35f4f501108bcf87598faf60415dbfba1d0cb.tar.bz2
historical-57b35f4f501108bcf87598faf60415dbfba1d0cb.zip
New Package
Diffstat (limited to 'dev-python/medusa/medusa-0.5.2.ebuild')
-rw-r--r--dev-python/medusa/medusa-0.5.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/medusa/medusa-0.5.2.ebuild b/dev-python/medusa/medusa-0.5.2.ebuild
new file mode 100644
index 000000000000..c16e2bde831f
--- /dev/null
+++ b/dev-python/medusa/medusa-0.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/medusa/medusa-0.5.2.ebuild,v 1.1 2002/12/17 07:45:56 tad Exp $
+
+DESCRIPTION="Medusa is a framework for writing long-running, high-performance network servers in Python, using asynchronous sockets"
+HOMEPAGE="http://oedipus.sourceforge.net/medusa/"
+SRC_URI="http://www.amk.ca/files/python/medusa-0.5.2.tar.gz"
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/python"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ python setup.py build || die
+}
+
+src_install () {
+ python setup.py install --prefix=${D}/usr || die
+ mkdir -p ${D}/usr/share/doc/${PF}/example
+ cp -R demo/* ${D}/usr/share/doc/${PF}/example
+ dodoc CHANGES.txt LICENSE.txt README.txt docs/*.txt
+ dohtml docs/*.html docs/*.gif
+}