summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-02 22:32:45 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-02 22:32:45 +0000
commitf463c3b2bbe3555cbf151e52bef648bc6f899253 (patch)
tree2c7b6a9d19942edcb79d594569bfbb609290a5f0 /dev-python/numeric
parentmoving dev-python/Numeric to dev-python/numeric (diff)
downloadhistorical-f463c3b2bbe3555cbf151e52bef648bc6f899253.tar.gz
historical-f463c3b2bbe3555cbf151e52bef648bc6f899253.tar.bz2
historical-f463c3b2bbe3555cbf151e52bef648bc6f899253.zip
moving dev-python/Numeric to dev-python/numeric
Diffstat (limited to 'dev-python/numeric')
-rw-r--r--dev-python/numeric/Manifest9
-rw-r--r--dev-python/numeric/files/digest-numeric-22.01
-rw-r--r--dev-python/numeric/files/digest-numeric-23.01
-rw-r--r--dev-python/numeric/files/digest-numeric-23.11
-rw-r--r--dev-python/numeric/metadata.xml5
-rw-r--r--dev-python/numeric/numeric-22.0.ebuild35
-rw-r--r--dev-python/numeric/numeric-23.0.ebuild35
-rw-r--r--dev-python/numeric/numeric-23.1.ebuild35
8 files changed, 118 insertions, 4 deletions
diff --git a/dev-python/numeric/Manifest b/dev-python/numeric/Manifest
index 189c337d4a89..b2042765b4cf 100644
--- a/dev-python/numeric/Manifest
+++ b/dev-python/numeric/Manifest
@@ -1,7 +1,8 @@
-MD5 c439a21c456a4bd7830e3dbbda5de872 ChangeLog 1343
-MD5 98ef718374a4c0a2f9655318a24c4379 numeric-22.0.ebuild 825
-MD5 c55753a734e80ec6a561607eb19b5788 numeric-23.0.ebuild 828
-MD5 c55753a734e80ec6a561607eb19b5788 numeric-23.1.ebuild 828
+MD5 c81b16890a48d672585153a1dfdf5653 ChangeLog 1555
+MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 7269221b1b32b7fd6d2b1cc7de01486c numeric-22.0.ebuild 828
+MD5 acb884870877f72a2d2d71e8db32913c numeric-23.0.ebuild 831
+MD5 2dd03f90c06969b8d8aea8b6e56318fc numeric-23.1.ebuild 831
MD5 543b62c79215183872d1f43ee1033c0b files/digest-numeric-22.0 64
MD5 1bbfd6024c1a372499b3774b2b91b5ab files/digest-numeric-23.0 64
MD5 a52c0be4669341bbf82129377ca75f2e files/digest-numeric-23.1 64
diff --git a/dev-python/numeric/files/digest-numeric-22.0 b/dev-python/numeric/files/digest-numeric-22.0
new file mode 100644
index 000000000000..12e3cad6bd11
--- /dev/null
+++ b/dev-python/numeric/files/digest-numeric-22.0
@@ -0,0 +1 @@
+MD5 222b71d150efa9be52622a288547d9d7 Numeric-22.0.tar.gz 722237
diff --git a/dev-python/numeric/files/digest-numeric-23.0 b/dev-python/numeric/files/digest-numeric-23.0
new file mode 100644
index 000000000000..cc2aa609b30d
--- /dev/null
+++ b/dev-python/numeric/files/digest-numeric-23.0
@@ -0,0 +1 @@
+MD5 2f8c3c5d0703ce12f55f04f43d1a9ab3 Numeric-23.0.tar.gz 723250
diff --git a/dev-python/numeric/files/digest-numeric-23.1 b/dev-python/numeric/files/digest-numeric-23.1
new file mode 100644
index 000000000000..c2381e866e71
--- /dev/null
+++ b/dev-python/numeric/files/digest-numeric-23.1
@@ -0,0 +1 @@
+MD5 5cd24ed20627f5cbc822a2bed8ff27e9 Numeric-23.1.tar.gz 724051
diff --git a/dev-python/numeric/metadata.xml b/dev-python/numeric/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/numeric/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/numeric/numeric-22.0.ebuild b/dev-python/numeric/numeric-22.0.ebuild
new file mode 100644
index 000000000000..99d086873091
--- /dev/null
+++ b/dev-python/numeric/numeric-22.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-22.0.ebuild,v 1.1 2003/09/02 22:24:02 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/n/N}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Numerical Python adds a fast, compact, multidimensional array language facility to Python."
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha"
+LICENSE="as-is"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_install() {
+
+ distutils_src_install
+ distutils_python_version
+
+ #Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${PYVER}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+
diff --git a/dev-python/numeric/numeric-23.0.ebuild b/dev-python/numeric/numeric-23.0.ebuild
new file mode 100644
index 000000000000..1cbab64beac1
--- /dev/null
+++ b/dev-python/numeric/numeric-23.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-23.0.ebuild,v 1.1 2003/09/02 22:24:02 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/n/N}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Numerical Python adds a fast, compact, multidimensional array language facility to Python."
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+LICENSE="as-is"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_install() {
+
+ distutils_src_install
+ distutils_python_version
+
+ #Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${PYVER}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+
diff --git a/dev-python/numeric/numeric-23.1.ebuild b/dev-python/numeric/numeric-23.1.ebuild
new file mode 100644
index 000000000000..3c7d63b0df9d
--- /dev/null
+++ b/dev-python/numeric/numeric-23.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numeric/numeric-23.1.ebuild,v 1.1 2003/09/02 22:24:02 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/n/N}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Numerical Python adds a fast, compact, multidimensional array language facility to Python."
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+LICENSE="as-is"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_install() {
+
+ distutils_src_install
+ distutils_python_version
+
+ #Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${PYVER}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+