summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-16 18:38:06 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-16 18:38:06 +0000
commit06eca87185977f5cb3874276418fc07e62486f50 (patch)
tree22b447803fa27d05e77149b82854abc09663ef1b /dev-python/numpy/numpy-1.6.1-r1.ebuild
parentAdd enhanced DEP support in fortran-2.eclass to easy the usage. Only inherit ... (diff)
downloadhistorical-06eca87185977f5cb3874276418fc07e62486f50.tar.gz
historical-06eca87185977f5cb3874276418fc07e62486f50.tar.bz2
historical-06eca87185977f5cb3874276418fc07e62486f50.zip
dev-python/numpy: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
Package-Manager: portage-2.2.0_alpha138/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'dev-python/numpy/numpy-1.6.1-r1.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.6.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/numpy/numpy-1.6.1-r1.ebuild b/dev-python/numpy/numpy-1.6.1-r1.ebuild
index 59e6572c78a2..c81566b1bc6b 100644
--- a/dev-python/numpy/numpy-1.6.1-r1.ebuild
+++ b/dev-python/numpy/numpy-1.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.1-r1.ebuild,v 1.14 2012/10/14 18:56:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.1-r1.ebuild,v 1.15 2012/10/16 18:38:04 jlec Exp $
EAPI=3
@@ -30,7 +30,7 @@ IUSE="doc lapack test"
RDEPEND="
dev-python/setuptools
- lapack? ( virtual/cblas virtual/lapack virtual/fortran )"
+ lapack? ( virtual/cblas virtual/lapack )"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )
lapack? ( virtual/pkgconfig )
@@ -44,7 +44,7 @@ PYTHON_NONVERSIONED_EXECUTABLES=("/usr/bin/f2py[[:digit:]]+\.[[:digit:]]+")
DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
pkg_setup() {
- use lapack && fortran-2_pkg_setup
+ fortran-2_pkg_setup
python_pkg_setup
# See progress in http://projects.scipy.org/scipy/numpy/ticket/573