summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-02-07 00:14:44 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-02-07 00:14:44 +0000
commita9606b29eba63c38c995c4fd7fbba21d8909b30a (patch)
tree86267ad1e2c1532374080ee4d8a8e15d35e5409f /dev-python/numpy
parentFix python bindings in 0.9.6, closes bug #121873. (diff)
downloadhistorical-a9606b29eba63c38c995c4fd7fbba21d8909b30a.tar.gz
historical-a9606b29eba63c38c995c4fd7fbba21d8909b30a.tar.bz2
historical-a9606b29eba63c38c995c4fd7fbba21d8909b30a.zip
initial ebuild thanks to Alok Singhal (#119305)
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog9
-rw-r--r--dev-python/numpy/Manifest14
-rw-r--r--dev-python/numpy/files/digest-numpy-0.9.41
-rw-r--r--dev-python/numpy/metadata.xml8
-rw-r--r--dev-python/numpy/numpy-0.9.4.ebuild32
5 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
new file mode 100644
index 000000000000..46e2aa764ec4
--- /dev/null
+++ b/dev-python/numpy/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/numpy
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.1 2006/02/07 00:14:44 liquidx Exp $
+
+*numpy-0.9.4 (07 Feb 2006)
+
+ 07 Feb 2006; Alastair Tse <liquidx@gentoo.org> +numpy-0.9.4.ebuild:
+ initial ebuild thanks to Alok Singhal (#119305)
+
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
new file mode 100644
index 000000000000..08aacf8dda1e
--- /dev/null
+++ b/dev-python/numpy/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 b09317a5c235fb501c713cac7f2fb5dc ChangeLog 355
+MD5 22d45be0cf5e365559a44bf0d4f5d512 files/digest-numpy-0.9.4 63
+MD5 485ea1fb2083d4705baa1e4efb747e95 metadata.xml 600
+MD5 94c5b949541bcce1eb89e86a79a3ad3c numpy-0.9.4.ebuild 719
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFD5+aJ9ZFPrqoILX8RArVxAJ4ykmBT5t62Qf2uJCC3ltgIWbyp1ACfQTA7
+UB+zibt907k/tpcv3abeufQ=
+=mKKW
+-----END PGP SIGNATURE-----
diff --git a/dev-python/numpy/files/digest-numpy-0.9.4 b/dev-python/numpy/files/digest-numpy-0.9.4
new file mode 100644
index 000000000000..d61e93e87426
--- /dev/null
+++ b/dev-python/numpy/files/digest-numpy-0.9.4
@@ -0,0 +1 @@
+MD5 104ef1beb4b0182be52e2c0849305427 numpy-0.9.4.tar.gz 908192
diff --git a/dev-python/numpy/metadata.xml b/dev-python/numpy/metadata.xml
new file mode 100644
index 000000000000..d53b9fa77242
--- /dev/null
+++ b/dev-python/numpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+This package contains a powerful N-dimensional array object, sophisticated (broadcasting) functions, tools for integrating C/C++ and Fortran code, and useful linear algebra, Fourier transform, and random number capabilities. It derives from the old Numeric code base and can be used as a replacement for Numeric. It also adds the features introduced by numarray and can be used to replace numarray.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/numpy/numpy-0.9.4.ebuild b/dev-python/numpy/numpy-0.9.4.ebuild
new file mode 100644
index 000000000000..d1970af034fb
--- /dev/null
+++ b/dev-python/numpy/numpy-0.9.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-0.9.4.ebuild,v 1.1 2006/02/07 00:14:44 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="Numpy contains a powerful N-dimensional array object for Python."
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://numeric.scipy.org/"
+DEPEND=">=dev-lang/python-2.3
+ virtual/lapack
+ virtual/blas"
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="BSD"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s: f77blas: blas:g" \
+ -e "s:'f77blas':'blas':g" \
+ numpy/distutils/system_info.py
+}
+
+src_install() {
+ distutils_src_install
+ dodoc numpy/doc/*
+}
+