summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeath Caldwell <hncaldwell@gentoo.org>2009-01-21 21:17:24 +0000
committerHeath Caldwell <hncaldwell@gentoo.org>2009-01-21 21:17:24 +0000
commitd170850b6206297ba94814cb3708a2f4b0c5aede (patch)
treeb8245b1d531b878cf8b0d6d4bba28bf830e6c230 /dev-python/pyaudio/pyaudio-0.2.3.ebuild
parentcleanup a bit redundant usemasks (diff)
downloadhistorical-d170850b6206297ba94814cb3708a2f4b0c5aede.tar.gz
historical-d170850b6206297ba94814cb3708a2f4b0c5aede.tar.bz2
historical-d170850b6206297ba94814cb3708a2f4b0c5aede.zip
New ebuild for pyaudio. Ebuild written by me.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyaudio/pyaudio-0.2.3.ebuild')
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pyaudio/pyaudio-0.2.3.ebuild b/dev-python/pyaudio/pyaudio-0.2.3.ebuild
new file mode 100644
index 000000000000..540933fd7b64
--- /dev/null
+++ b/dev-python/pyaudio/pyaudio-0.2.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyaudio/pyaudio-0.2.3.ebuild,v 1.1 2009/01/21 21:17:24 hncaldwell Exp $
+
+DESCRIPTION="Python bindings for PortAudio"
+HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
+SRC_URI="http://people.csail.mit.edu/hubert/pyaudio/packages/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ media-libs/portaudio"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python setup.py install --root="${D}" || die
+}