summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-11-23 15:52:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-11-23 15:52:21 +0000
commit9e02d85a482d3bf715b89e08e6e54ebbc633a9ba (patch)
tree01dfbc4cebb56cc6c9d5f6b59214ee9adb181c3b /dev-python/pyorbit
parentstable on x86 (diff)
downloadhistorical-9e02d85a482d3bf715b89e08e6e54ebbc633a9ba.tar.gz
historical-9e02d85a482d3bf715b89e08e6e54ebbc633a9ba.tar.bz2
historical-9e02d85a482d3bf715b89e08e6e54ebbc633a9ba.zip
version bump, moving CORBA.py and PortableServer.py to avoid colliding with omniorbpy
Diffstat (limited to 'dev-python/pyorbit')
-rw-r--r--dev-python/pyorbit/ChangeLog8
-rw-r--r--dev-python/pyorbit/Manifest2
-rw-r--r--dev-python/pyorbit/files/digest-pyorbit-2.0.11
-rw-r--r--dev-python/pyorbit/pyorbit-2.0.1.ebuild49
4 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/pyorbit/ChangeLog b/dev-python/pyorbit/ChangeLog
index 223139491305..d225522a299d 100644
--- a/dev-python/pyorbit/ChangeLog
+++ b/dev-python/pyorbit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyorbit
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/ChangeLog,v 1.14 2004/06/25 01:41:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/ChangeLog,v 1.15 2004/11/23 15:52:21 liquidx Exp $
+
+*pyorbit-2.0.1 (23 Nov 2004)
+
+ 23 Nov 2004; Alastair Tse <liquidx@gentoo.org> +pyorbit-2.0.1.ebuild:
+ version bump, moving CORBA.py and PortableServer.py to avoid colliding with
+ omniorbpy
23 Mar 2004; Chris Aniszczyk <zx@gentoo.org> pyorbit-2.0.0.ebuild:
Added ~hppa
diff --git a/dev-python/pyorbit/Manifest b/dev-python/pyorbit/Manifest
index 22ec204c71cb..945820981157 100644
--- a/dev-python/pyorbit/Manifest
+++ b/dev-python/pyorbit/Manifest
@@ -1,4 +1,6 @@
MD5 6ea10825f95e231ba632ab5da722197c ChangeLog 1593
MD5 7f4b1ac767214657b085c4951227af02 metadata.xml 178
MD5 4a397f5ab5a6206e7fd647ebc4e6434e pyorbit-2.0.0.ebuild 617
+MD5 4a397f5ab5a6206e7fd647ebc4e6434e pyorbit-2.0.1.ebuild 617
MD5 9d3297219d639bea2af5b40eac57dd24 files/digest-pyorbit-2.0.0 66
+MD5 e95549f9bb22fc658bfede9a5690dd2a files/digest-pyorbit-2.0.1 66
diff --git a/dev-python/pyorbit/files/digest-pyorbit-2.0.1 b/dev-python/pyorbit/files/digest-pyorbit-2.0.1
new file mode 100644
index 000000000000..9c5f7691897e
--- /dev/null
+++ b/dev-python/pyorbit/files/digest-pyorbit-2.0.1
@@ -0,0 +1 @@
+MD5 c39384f6257a386231d79db9e403d905 pyorbit-2.0.1.tar.bz2 242959
diff --git a/dev-python/pyorbit/pyorbit-2.0.1.ebuild b/dev-python/pyorbit/pyorbit-2.0.1.ebuild
new file mode 100644
index 000000000000..005deb466afa
--- /dev/null
+++ b/dev-python/pyorbit/pyorbit-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyorbit/pyorbit-2.0.1.ebuild,v 1.1 2004/11/23 15:52:21 liquidx Exp $
+
+inherit python gnome2
+
+DESCRIPTION="ORBit2 bindings for Python"
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.2
+ >=gnome-base/orbit-2.4.4"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_version
+ mv ${D}/usr/lib/python${PYVER}/site-packages/CORBA.py \
+ ${D}/usr/lib/python${PYVER}/site-packages/pyorbit_CORBA.py
+
+ mv ${D}/usr/lib/python${PYVER}/site-packages/PortableServer.py \
+ ${D}/usr/lib/python${PYVER}/site-packages/pyorbit_PortableServer.py
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+} \ No newline at end of file