summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 03:07:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 03:07:41 +0000
commitb8b644f00bc7611c48c7305c5c77c759b6116a2d (patch)
tree3e8776152eaf000f1f0824aec7c6e9e5e464fb7e /dev-python/pyqwt
parentVersion bump. Fix dependencies (bug #303317). (diff)
downloadhistorical-b8b644f00bc7611c48c7305c5c77c759b6116a2d.tar.gz
historical-b8b644f00bc7611c48c7305c5c77c759b6116a2d.tar.bz2
historical-b8b644f00bc7611c48c7305c5c77c759b6116a2d.zip
Set SUPPORT_PYTHON_ABIS. Require >=dev-python/PyQt4-4.6.1 to avoid file collision (bug #303673). Delete unused "debug" USE flag.
Package-Manager: portage-15325-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyqwt')
-rw-r--r--dev-python/pyqwt/ChangeLog9
-rw-r--r--dev-python/pyqwt/Manifest4
-rw-r--r--dev-python/pyqwt/pyqwt-5.2.0.ebuild47
3 files changed, 35 insertions, 25 deletions
diff --git a/dev-python/pyqwt/ChangeLog b/dev-python/pyqwt/ChangeLog
index 3964e3d84891..b80fbcd85821 100644
--- a/dev-python/pyqwt/ChangeLog
+++ b/dev-python/pyqwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyqwt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.15 2009/12/28 05:07:28 yngwin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.16 2010/02/07 03:07:41 arfrever Exp $
+
+ 07 Feb 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyqwt-5.2.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS. Require >=dev-python/PyQt4-4.6.1 to avoid file
+ collision (bug #303673). Delete unused "debug" USE flag.
*pyqwt-5.2.0 (27 Dec 2009)
diff --git a/dev-python/pyqwt/Manifest b/dev-python/pyqwt/Manifest
index 5653e4da607e..b6a466a385a3 100644
--- a/dev-python/pyqwt/Manifest
+++ b/dev-python/pyqwt/Manifest
@@ -1,4 +1,4 @@
DIST PyQwt-5.2.0.tar.gz 2670893 RMD160 e4c8a63d623d974cd500e29fbc62255746ca7feb SHA1 797f37c63dec660272f6a8ccfd16a017df0ad640 SHA256 98a8c7e0c76d07701c11dffb77793b05f071b664a8b520d6e97054a98179e70b
-EBUILD pyqwt-5.2.0.ebuild 1340 RMD160 dd3b5dffef40ee648ca437f571c1a2b4c982a5e9 SHA1 db6e3e1469ba527ae652f40d80e91ae7cdfed9fd SHA256 edd9d69423ca7b32990b54aec670c4842c34d6c95a8a46c26fc0fa5bdfbeab73
-MISC ChangeLog 2059 RMD160 de94ad156c1e60d76e7fea9c538510eba8fd3966 SHA1 bed0993b374829d851eeffa1910521fbb120aa60 SHA256 94ff0c12286a20ef842d08cc72cad05100ef1ff1b49ee72fa95cfb122a474f5d
+EBUILD pyqwt-5.2.0.ebuild 1400 RMD160 8906514eaeaeb284998a3f4b1378f8843849ad23 SHA1 ccabbc65558fdd33b199f7cc54a50752cb696f41 SHA256 37d8e42e70e56bc46d1a49de0e01f176a4aa5b51c2c77d2ad7a293294ba9135d
+MISC ChangeLog 2290 RMD160 e6a173dd16714bf3ec6f8cb6541b9758526f237f SHA1 82513ff3119b616260a1054ea9796750b46073ec SHA256 b855de457c9d1f5b8eed70fe780869509d9e5dc3b0ab24df700ae1d8601f0d1c
MISC metadata.xml 521 RMD160 10513e9e3c74a998a8caab9a59706d3265de41ce SHA1 59cb897be1e2bf4bbe7e1b13dae037fa9bbb421d SHA256 c5fbc6c9f37a975d7f1f6f548b3163c8dbbf282647e40abadeb8ace8e3bff441
diff --git a/dev-python/pyqwt/pyqwt-5.2.0.ebuild b/dev-python/pyqwt/pyqwt-5.2.0.ebuild
index 403e926e93ba..38f2c567eedc 100644
--- a/dev-python/pyqwt/pyqwt-5.2.0.ebuild
+++ b/dev-python/pyqwt/pyqwt-5.2.0.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0.ebuild,v 1.3 2010/01/31 07:39:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0.ebuild,v 1.4 2010/02/07 03:07:41 arfrever Exp $
-EAPI=2
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
-inherit python flag-o-matic
+inherit flag-o-matic python
MY_P="PyQwt-${PV}"
DESCRIPTION="Python bindings for the Qwt library"
@@ -14,38 +17,40 @@ HOMEPAGE="http://pyqwt.sourceforge.net/"
SLOT="5"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="debug doc examples svg"
+IUSE="doc examples svg"
RDEPEND=">=x11-libs/qwt-5.1[svg?]
- dev-python/PyQt4
+ >=dev-python/PyQt4-4.6.1
dev-python/numpy"
DEPEND="${DEPEND}
dev-python/sip"
-
-RESTRICT_PYTHON_ABIS="2.4 2.7 3.*"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}/configure"
+pkg_setup() {
+ append-flags -fPIC
+}
+
src_configure() {
+ configuration() {
+ # '-j' option can be buggy.
+ "$(PYTHON)" configure.py \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt || return 1
- append-flags -fPIC
+ # Avoid stripping of the libraries.
+ sed -i -e "/strip/d" {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
+ }
+ python_execute_function -s configuration
- # the -j option can be buggy
- python_version
- "${python}" configure.py \
- --disable-numarray \
- --disable-numeric \
- -I/usr/include/qwt5 \
- -lqwt \
- || die "python configure.py failed"
-
- # avoiding strip the libraries
- sed -i -e '/strip/d' {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
}
src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_src_install
+
cd ..
dodoc ANNOUNCEMENT-${PV} README
if use doc; then