summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2013-07-18 19:33:35 +0000
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2013-07-18 19:33:35 +0000
commit0db4c371ffc5485485ed97645ee1fbce9a4fdc58 (patch)
tree7799423a1bf1f079045c82dcc5640cf7840d41e5 /dev-python/pyro/pyro-4.20.ebuild
parentadd virtual/service-manager for bug #409385 (diff)
downloadhistorical-0db4c371ffc5485485ed97645ee1fbce9a4fdc58.tar.gz
historical-0db4c371ffc5485485ed97645ee1fbce9a4fdc58.tar.bz2
historical-0db4c371ffc5485485ed97645ee1fbce9a4fdc58.zip
Fixed tests for Python 2.6 and 3.1.
Package-Manager: portage-2.1.12.11/cvs/Linux x86_64 Manifest-Sign-Key: 0xF0134531E1DBFAB5
Diffstat (limited to 'dev-python/pyro/pyro-4.20.ebuild')
-rw-r--r--dev-python/pyro/pyro-4.20.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pyro/pyro-4.20.ebuild b/dev-python/pyro/pyro-4.20.ebuild
index 64cda8984874..ed7ff14bb6f6 100644
--- a/dev-python/pyro/pyro-4.20.ebuild
+++ b/dev-python/pyro/pyro-4.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.20.ebuild,v 1.1 2013/07/10 14:30:15 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.20.ebuild,v 1.2 2013/07/18 19:33:31 aidecoe Exp $
EAPI=5
@@ -27,12 +27,18 @@ DEPEND="${RDEPEND}
test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
+ python_targets_python2_6? (
+ dev-python/unittest2[python_targets_python2_6] )
+ python_targets_python3_1? (
+ dev-python/unittest2[python_targets_python3_1] )
)"
S="${WORKDIR}/${MY_P}"
DISTUTILS_IN_SOURCE_BUILD=1
python_prepare_all() {
+ epatch "${FILESDIR}/${PV}-0001-Use-unittest2-for-older-Python-version.patch"
+
sed \
-e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' \
-i tests/run_suite.py || die