summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-17 11:18:04 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-17 11:18:04 +0000
commit87a41a02c7d314062e7503070dcaa1221b6c0568 (patch)
treeaacc1637a0c4f7802ba480556107db0453adc6e3 /dev-python/python-ldap/python-ldap-2.4.18.ebuild
parentBump to 4.8, thanks to slepnoga (diff)
downloadhistorical-87a41a02c7d314062e7503070dcaa1221b6c0568.tar.gz
historical-87a41a02c7d314062e7503070dcaa1221b6c0568.tar.bz2
historical-87a41a02c7d314062e7503070dcaa1221b6c0568.zip
correction to deps, noted by Arfrever
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/python-ldap/python-ldap-2.4.18.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-2.4.18.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/python-ldap/python-ldap-2.4.18.ebuild b/dev-python/python-ldap/python-ldap-2.4.18.ebuild
index d2aee1ca0769..de9a28883e93 100644
--- a/dev-python/python-ldap/python-ldap-2.4.18.ebuild
+++ b/dev-python/python-ldap/python-ldap-2.4.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.4.18.ebuild,v 1.1 2014/10/17 07:31:18 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.4.18.ebuild,v 1.2 2014/10/17 11:17:34 idella4 Exp $
EAPI=5
@@ -21,13 +21,14 @@ IUSE="doc examples sasl ssl"
# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
# python team: Please do not remove python-ldap-2.3.9 from the tree.
# OpenSSL is an optional runtime dep.
+# setup.py's install_requires entry is a debacle.
RDEPEND=">net-nds/openldap-2.4.11
dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}] )"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
python_prepare_all() {
sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
@@ -66,7 +67,7 @@ python_test() {
}
python_install_all() {
- use examples && local EXAMPLES=( Demo/. )
+. use examples && local EXAMPLES=( Demo/. )
use doc && local HTML_DOCS=( Doc/.build/html/. )
distutils-r1_python_install_all