summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-08-29 17:14:27 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-08-29 17:14:27 +0000
commit652964e2fbd64b610e8ca9d1162cd63916071c1c (patch)
tree76157740d5c5295eeba076e6df1c19d88a8683bc /dev-python/pyxml/pyxml-0.8.3.ebuild
parentmoving from dev-python/PyXML to dev-python/pyxml (diff)
downloadhistorical-652964e2fbd64b610e8ca9d1162cd63916071c1c.tar.gz
historical-652964e2fbd64b610e8ca9d1162cd63916071c1c.tar.bz2
historical-652964e2fbd64b610e8ca9d1162cd63916071c1c.zip
moving from dev-python/PyXML to dev-python/pyxml
Diffstat (limited to 'dev-python/pyxml/pyxml-0.8.3.ebuild')
-rw-r--r--dev-python/pyxml/pyxml-0.8.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyxml/pyxml-0.8.3.ebuild b/dev-python/pyxml/pyxml-0.8.3.ebuild
new file mode 100644
index 000000000000..1cf5b3e6afc8
--- /dev/null
+++ b/dev-python/pyxml/pyxml-0.8.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.3.ebuild,v 1.1 2003/08/29 17:14:21 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/pyxml/PyXML}
+
+DESCRIPTION="A collection of libraries to process XML with Python."
+SRC_URI="mirror://sourceforge/pyxml/${MY_P}.tar.gz"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=dev-libs/expat-1.95.6"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha hppa amd64"
+LICENSE="PYTHON"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ # if you want to use 4Suite, then their XSLT/XPATH is
+ # better according to the docs
+ if has_version "dev-python/4Suite"; then
+ myconf="--without-xslt --without-xpath"
+ fi
+
+ distutils_src_compile ${myconf}
+}
+
+src_install() {
+ mydoc="ANNOUNCE CREDITS PKG-INFO"
+ distutils_src_install
+
+ dohtml -r doc/*
+}