summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-05-21 08:47:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-05-21 08:47:47 +0000
commit6318df416201bdc3ba162253096cfe19715e22cb (patch)
tree9d58f517730278cea6838c669155b7d91a74f3da /dev-python/pyzmq/pyzmq-2.2.0.ebuild
parentStable for x86, wrt bug #381981 (diff)
downloadhistorical-6318df416201bdc3ba162253096cfe19715e22cb.tar.gz
historical-6318df416201bdc3ba162253096cfe19715e22cb.tar.bz2
historical-6318df416201bdc3ba162253096cfe19715e22cb.zip
Bump for #416639
Package-Manager: portage-2.2.0_alpha107/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyzmq/pyzmq-2.2.0.ebuild')
-rw-r--r--dev-python/pyzmq/pyzmq-2.2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyzmq/pyzmq-2.2.0.ebuild b/dev-python/pyzmq/pyzmq-2.2.0.ebuild
new file mode 100644
index 000000000000..39ddfcb85b59
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyzmq/pyzmq-2.2.0.ebuild,v 1.1 2012/05/21 08:47:47 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 *-jython 2.7-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+PYTHON_TESTS_RESTRICTED_ABIS="3*"
+
+inherit distutils eutils
+
+DESCRIPTION="PyZMQ is a lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=net-libs/zeromq-2.1.9"
+DEPEND="${RDEPEND}
+ test? ( www-servers/tornado )"
+
+DOCS="README.rst"
+PYTHON_MODNAME="zmq"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests -sv $(ls -d build-${PYTHON_ABI}/lib.*)
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}