summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-01 09:11:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-01 09:11:05 +0000
commiteb5abbd7134043add96ab1109bacf1a61b2fb1d5 (patch)
tree2582c229bba52db1a7879da5003c113c9e63779e /dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild
parentVersion bump (diff)
downloadhistorical-eb5abbd7134043add96ab1109bacf1a61b2fb1d5.tar.gz
historical-eb5abbd7134043add96ab1109bacf1a61b2fb1d5.tar.bz2
historical-eb5abbd7134043add96ab1109bacf1a61b2fb1d5.zip
Version bump
Package-Manager: portage-2.2_rc72/cvs/Linux x86_64
Diffstat (limited to 'dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild')
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild
new file mode 100644
index 000000000000..c48ffadce582
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild,v 1.1 2010/09/01 09:11:05 hwoarang Exp $
+
+EAPI="2"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python toolchain-funcs
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=dev-python/sip-4.10
+ >=dev-python/PyQt4-4.7[X]
+ ~x11-libs/qscintilla-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/Python"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4-nostrip.patch
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py -p 4
+ --destdir=$(python_get_sitedir)/PyQt4
+ $(use debug && echo '--debug')"
+ echo ${myconf}
+ ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
+ }
+ python_execute_function -s building
+}