summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-07-01 09:59:04 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-07-01 09:59:04 +0000
commit84e7aa19769248cb8701f4fce4b8c2bd57fb36e9 (patch)
tree321f0468a129dfceb4260bf8e451d00be16ea581 /dev-python/roman/roman-2.0.0.ebuild
parentMigrate to distutils-r1 (diff)
downloadhistorical-84e7aa19769248cb8701f4fce4b8c2bd57fb36e9.tar.gz
historical-84e7aa19769248cb8701f4fce4b8c2bd57fb36e9.tar.bz2
historical-84e7aa19769248cb8701f4fce4b8c2bd57fb36e9.zip
Version bump which introduces tests and pypy/py-3.3 compatibility.
Package-Manager: portage-2.1.11.63/cvs/Linux x86_64 Manifest-Sign-Key: 0x1E0CA85F!
Diffstat (limited to 'dev-python/roman/roman-2.0.0.ebuild')
-rw-r--r--dev-python/roman/roman-2.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/roman/roman-2.0.0.ebuild b/dev-python/roman/roman-2.0.0.ebuild
new file mode 100644
index 000000000000..33375ead6de6
--- /dev/null
+++ b/dev-python/roman/roman-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/roman/roman-2.0.0.ebuild,v 1.1 2013/07/01 09:59:03 dev-zero Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="http://pypi.python.org/pypi/roman/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="!<dev-python/docutils-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
+
+python_test() {
+ cp "${S}/src/tests.py" . || die "copying test file failed"
+ esetup.py test
+}