summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:04:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:04:44 +0000
commitd8350dac981d64d767867dcef45a39e6079149ae (patch)
tree0f6827e14b85599bad87609b98ce871d4a9f8f1f /dev-python/setuptools
parentUse -j1 for make. Bug #279962. (diff)
downloadhistorical-d8350dac981d64d767867dcef45a39e6079149ae.tar.gz
historical-d8350dac981d64d767867dcef45a39e6079149ae.tar.bz2
historical-d8350dac981d64d767867dcef45a39e6079149ae.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-13874-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog8
-rw-r--r--dev-python/setuptools/setuptools-0.6_rc9-r1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index 6fc07a86b256..3d9d1e68e8df 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.52 2009/04/27 16:57:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.53 2009/08/01 22:56:50 arfrever Exp $
+
+*setuptools-0.6_rc9-r1 (28 Jul 2009)
+
+ 28 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +setuptools-0.6_rc9-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
27 Apr 2009; Jeroen Roovers <jer@gentoo.org> setuptools-0.6_rc9.ebuild:
Stable for HPPA (bug #267209).
diff --git a/dev-python/setuptools/setuptools-0.6_rc9-r1.ebuild b/dev-python/setuptools/setuptools-0.6_rc9-r1.ebuild
new file mode 100644
index 000000000000..2b6349d7aef0
--- /dev/null
+++ b/dev-python/setuptools/setuptools-0.6_rc9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-0.6_rc9-r1.ebuild,v 1.1 2009/08/01 22:56:50 arfrever Exp $
+
+NEED_PYTHON="2.4"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_P="${P/_rc/c}"
+
+DESCRIPTION="A collection of enhancements to the Python distutils including easy install"
+HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
+SRC_URI="http://cheeseshop.python.org/packages/source/s/setuptools/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="EasyInstall.txt api_tests.txt pkg_resources.txt setuptools.txt README.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.6_rc7-noexe.patch"
+
+ # Remove tests that access the network (bugs #198312, #191117)
+ rm setuptools/tests/test_packageindex.py
+}
+
+src_test() {
+ tests() {
+ PYTHONPATH="." "${python}" setup.py test
+ }
+ python_execute_function tests
+}