summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Bainbridge <chrb@gentoo.org>2005-09-22 23:25:37 +0000
committerChris Bainbridge <chrb@gentoo.org>2005-09-22 23:25:37 +0000
commit4816c23e1bad8e9fd4e11b5c2123a20f5df72fa6 (patch)
tree36f989415e13e54f2fea4a9272ee209a2bb091d3 /dev-python/sip/sip-4.3.1.ebuild
parentAdded non-root changes (with little modifications) submitted by CJ Kucera in ... (diff)
downloadhistorical-4816c23e1bad8e9fd4e11b5c2123a20f5df72fa6.tar.gz
historical-4816c23e1bad8e9fd4e11b5c2123a20f5df72fa6.tar.bz2
historical-4816c23e1bad8e9fd4e11b5c2123a20f5df72fa6.zip
Version bump, fixed LICENSE, bug #93575.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-python/sip/sip-4.3.1.ebuild')
-rw-r--r--dev-python/sip/sip-4.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sip/sip-4.3.1.ebuild b/dev-python/sip/sip-4.3.1.ebuild
new file mode 100644
index 000000000000..2b00bd1c9fb9
--- /dev/null
+++ b/dev-python/sip/sip-4.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.3.1.ebuild,v 1.1 2005/09/22 23:25:37 chrb Exp $
+
+inherit distutils
+
+MY_P=${P/"?.?.?_pre"/"snapshot-"}
+MY_P=${MY_P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/sip/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="sip"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND="virtual/libc
+ x11-libs/qt
+ >=dev-lang/python-2.3"
+
+src_compile(){
+ distutils_python_version
+
+ local myconf="-l qt-mt -b /usr/bin -d /usr/$(get_libdir)/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README THANKS TODO
+ if use doc ; then dohtml doc/* ; fi
+}
+
+pkg_postinst() {
+ echo ""
+ einfo "Please note, that you have to emerge PyQt again, when upgrading from sip-3.x."
+ echo ""
+}