summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2012-05-20 13:56:48 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2012-05-20 13:56:48 +0000
commitca59044fc4f863ca30ad0558044b3947c3b77b23 (patch)
tree2094daa049554f0422fd3e1642e667c9026db5bb /dev-python/testfixtures
parentRegenerate docbook documentation for testsuite wrt #416721 (diff)
downloadhistorical-ca59044fc4f863ca30ad0558044b3947c3b77b23.tar.gz
historical-ca59044fc4f863ca30ad0558044b3947c3b77b23.tar.bz2
historical-ca59044fc4f863ca30ad0558044b3947c3b77b23.zip
Initial commit, ebuild by idella4
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/ChangeLog11
-rw-r--r--dev-python/testfixtures/Manifest15
-rw-r--r--dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch130
-rw-r--r--dev-python/testfixtures/metadata.xml10
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild50
5 files changed, 216 insertions, 0 deletions
diff --git a/dev-python/testfixtures/ChangeLog b/dev-python/testfixtures/ChangeLog
new file mode 100644
index 000000000000..8f4e1de33850
--- /dev/null
+++ b/dev-python/testfixtures/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/testfixtures
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/ChangeLog,v 1.1 2012/05/20 13:56:48 tampakrap Exp $
+
+*testfixtures-2.3.4 (20 May 2012)
+
+ 20 May 2012; Theo Chatzimichos <tampakrap@gentoo.org>
+ +files/testfixtures-2.3.4-adjust_tests.patch, +metadata.xml,
+ +testfixtures-2.3.4.ebuild:
+ Initial commit, ebuild by idella4
+
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
new file mode 100644
index 000000000000..d7d66f955d68
--- /dev/null
+++ b/dev-python/testfixtures/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX testfixtures-2.3.4-adjust_tests.patch 4904 RMD160 47250e9cb708b90524b01ceb4d657519fcba7a55 SHA1 2b20c9b7415df665a71abcc17546c50de69f757b SHA256 6197835fb3c2089e0913d4029ed8ef07b7dbb24057dcfe152d3470379804a790
+DIST testfixtures-2.3.4.tar.gz 73214 SHA256 376530e6608f072f6655d6a6de495a717040d47db5b04f2afac95ea7041af851 SHA512 858ebe20c0a2d682c2652a14a3e2fceea2e148f1e50d658f20237f3b15a84cf67ad61ff1d6b4a4b6c0a27981b337cf634b6b33fa7f717b7b9a5ceb289b396e47 WHIRLPOOL 4e6d7a8fd1fbac9d2f1c6b769ee810619b8a1db2d24469e7ac14867f19e92b7d0bc9596c09df3c80888dbf71350ddd80134b28564985de144cb3cfab2572d934
+EBUILD testfixtures-2.3.4.ebuild 1257 RMD160 51f69bb0ec83fd21197747fecd862b0bdab67243 SHA1 fb35f38873af6bd31062b4e79d2cb7b21d3d6fc4 SHA256 7e1a507b1c2c84b99145156fe52944f3b2c71dce0e352fed25ddb788aac137be
+MISC ChangeLog 443 RMD160 8571477fe89e716e50c059e6de6dc87b552b34b0 SHA1 7a7fabdaf7e506cbf3dbc396fb5e5c0090f68c32 SHA256 5374d3cf916d123b73fc25637efe7e581c8459669b99fb56a311f14290a19d53
+MISC metadata.xml 400 RMD160 91c7f35b130ffa540c3158e77ab8c5be8e58a727 SHA1 300ec157fc6880808bf017302a0d4ce87ee52fe2 SHA256 7e2b5da1970841ff8650a795052b962c6d8d28819aa980bb30407ec5d09e5299
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEARECAAYFAk+4+OYACgkQjDdoMVfcAHh9gQCgtt64foAJEmUVPrtMjENNqa4U
+If8AoIpWew3mCC5UGkrUD/jqrF3OKpRP
+=Yvd5
+-----END PGP SIGNATURE-----
diff --git a/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch b/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch
new file mode 100644
index 000000000000..590bb796b7b7
--- /dev/null
+++ b/dev-python/testfixtures/files/testfixtures-2.3.4-adjust_tests.patch
@@ -0,0 +1,130 @@
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_comparison.py testfixtures-2.3.4/testfixtures/tests/test_comparison.py
+--- testfixtures/tests/test_comparison.py 2012-01-26 18:00:05.000000000 +0800
++++ testfixtures/tests/test_comparison.py 2012-04-13 19:00:15.856224293 +0800
+@@ -5,7 +5,7 @@
+ from testfixtures.tests.sample1 import TestClassA,a_function
+ from unittest import TestCase,TestSuite,makeSuite
+
+-from .compat import py_27_plus
++from compat import py_27_plus
+
+ class AClass:
+
+diff -ur testfixtures-2.3.4.orig/tests/test_components.py testfixtures-2.3.4/testfixtures/tests/test_components.py
+--- testfixtures/tests/test_components.py 2012-01-27 02:41:51.000000000 +0800
++++ testfixtures/tests/test_components.py 2012-04-13 19:08:44.434220585 +0800
+@@ -14,7 +14,7 @@
+ from testfixtures import compare
+ from unittest import TestCase
+
+-from .compat import catch_warnings
++from compat import catch_warnings
+
+ class ComponentsTests(TestCase):
+
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_docs.py testfixtures-2.3.4/testfixtures/tests/test_docs.py
+--- testfixtures/tests/test_docs.py 2012-01-28 16:07:57.000000000 +0800
++++ testfixtures/tests/test_docs.py 2012-04-13 19:03:36.649223003 +0800
+@@ -11,7 +11,7 @@
+
+ import os
+
+-from . import compat
++import compat
+
+ workspace = os.environ.get('WORKSPACE', join(dirname(__file__), pardir, pardir))
+ tests = glob(join(workspace,'docs', '*.txt'))
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_logcapture.py testfixtures-2.3.4/testfixtures/tests/test_logcapture.py
+--- testfixtures/tests/test_logcapture.py 2012-01-27 02:41:26.000000000 +0800
++++ testfixtures/tests/test_logcapture.py 2012-04-13 19:09:02.930220838 +0800
+@@ -10,7 +10,7 @@
+
+ from logging import getLogger
+
+-from .compat import catch_warnings
++from compat import catch_warnings
+
+ root = getLogger()
+ one = getLogger('one')
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_replace.py testfixtures-2.3.4/testfixtures/tests/test_replace.py
+--- testfixtures/tests/test_replace.py 2012-01-27 02:34:12.000000000 +0800
++++ testfixtures/tests/test_replace.py 2012-04-13 19:09:18.842220416 +0800
+@@ -17,7 +17,7 @@
+ import sample1
+ import sample2
+
+-from .compat import catch_warnings
++from compat import catch_warnings
+
+ class TestReplace(TestCase):
+
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_should_raise.py testfixtures-2.3.4/testfixtures/tests/test_should_raise.py
+--- testfixtures/tests/test_should_raise.py 2012-01-27 02:43:51.000000000 +0800
++++ testfixtures/tests/test_should_raise.py 2012-04-13 19:09:36.235220628 +0800
+@@ -5,7 +5,7 @@
+ from testfixtures import should_raise,ShouldRaise,Comparison as C
+ from unittest import TestCase,TestSuite,makeSuite
+
+-from .compat import py_27_plus
++from compat import py_27_plus
+
+ class TestShouldRaise(TestCase):
+
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_tempdirectory.py testfixtures-2.3.4/testfixtures/tests/test_tempdirectory.py
+--- testfixtures/tests/test_tempdirectory.py 2012-01-27 02:25:43.000000000 +0800
++++ testfixtures/tests/test_tempdirectory.py 2012-04-13 19:09:54.971220623 +0800
+@@ -13,7 +13,7 @@
+
+ from logging import getLogger
+
+-from .compat import catch_warnings
++from compat import catch_warnings
+
+ class DemoTempDirectory:
+
+diff -ur testfixtures-2.3.4.orig/testfixtures/tests/test_manuel_examples.py testfixtures-2.3.4/testfixtures/tests/test_manuel_examples.py
+--- testfixtures/tests/test_manuel_examples.py 2012-01-26 04:31:12.000000000 +0800
++++ testfixtures/tests/test_manuel_examples.py 2012-04-13 21:14:05.390172684 +0800
+@@ -11,7 +11,7 @@
+ from testfixtures import TempDirectory
+ from testfixtures.manuel import Files
+
+-from . import compat
++import compat
+
+ def setUp(test):
+ test.globs['tempdir']=TempDirectory()
+diff -ur testfixtures-2.3.4.orig/testfixtures/components.py testfixtures-2.3.4/testfixtures/components.py
+--- testfixtures/components.py 2011-10-12 00:21:45.000000000 +0800
++++ testfixtures/components.py 2012-04-29 18:12:41.891588669 +0800
+@@ -4,8 +4,8 @@
+ import atexit
+ import warnings
+
+-from zope.component import getSiteManager
+-from zope.component.registry import Components
++#from zope.component import getSiteManager
++#from zope.component.registry import Components
+
+ class TestComponents:
+ """
+@@ -20,11 +20,8 @@
+ atexit_setup = False
+
+ def __init__(self):
+- self.registry = Components('Testing')
+- self.old = getSiteManager.sethook(lambda:self.registry)
+ self.instances.add(self)
+ if not self.__class__.atexit_setup:
+- atexit.register(self.atexit)
+ self.__class__.atexit_setup = True
+
+ def uninstall(self):
+@@ -33,7 +30,6 @@
+ was in place before this :class:`TestComponents` was
+ instantiated.
+ """
+- getSiteManager.sethook(self.old)
+ self.instances.remove(self)
+
+ @classmethod
diff --git a/dev-python/testfixtures/metadata.xml b/dev-python/testfixtures/metadata.xml
new file mode 100644
index 000000000000..bfe30823be5b
--- /dev/null
+++ b/dev-python/testfixtures/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>della5@iinet.com.au</email>
+ <name>Ian Delaney aka idella4 proxy maintainer</name>
+ </maintainer>
+ <maintainer><email>tampakrap@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
new file mode 100644
index 000000000000..930c26781c75
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testfixtures/testfixtures-2.3.4.ebuild,v 1.1 2012/05/20 13:56:48 tampakrap Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
+DISTUTILS_SRC_TEST="py.test"
+inherit distutils eutils
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="http://pypi.python.org/pypi/testfixtures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+# test? ( net-zope/zope-component )"
+
+src_prepare() {
+ sed -e s':../bin/sphinx-build:/usr/bin/sphinx-build:' \
+ -i docs/Makefile || die
+ epatch "${FILESDIR}"/${P}-adjust_tests.patch
+
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+ distutils_src_prepare
+}
+src_compile() {
+ distutils_src_compile
+
+ use doc && emake -C docs html
+}
+
+src_test() {
+ distutils_src_test ${PN}/tests/
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r docs/_build/html/
+ fi
+}