summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-03-17 10:42:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-03-17 10:42:19 +0000
commit51b2627f5acac0d31533ad3ca4313c5ddfe5baf6 (patch)
treeb34ef10e3fdfc1e0cc373a2f7cf3e3338dddc765 /dev-python/twisted-conch
parentAutomated update of use.local.desc (diff)
downloadhistorical-51b2627f5acac0d31533ad3ca4313c5ddfe5baf6.tar.gz
historical-51b2627f5acac0d31533ad3ca4313c5ddfe5baf6.tar.bz2
historical-51b2627f5acac0d31533ad3ca4313c5ddfe5baf6.zip
Bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-python/twisted-conch')
-rw-r--r--dev-python/twisted-conch/ChangeLog8
-rw-r--r--dev-python/twisted-conch/twisted-conch-10.0.0.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
index f88c6c8953ca..62ac6f962231 100644
--- a/dev-python/twisted-conch/ChangeLog
+++ b/dev-python/twisted-conch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-conch
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.54 2010/02/13 17:42:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.55 2010/03/17 10:39:45 patrick Exp $
+
+*twisted-conch-10.0.0 (17 Mar 2010)
+
+ 17 Mar 2010; Patrick Lauer <patrick@gentoo.org>
+ +twisted-conch-10.0.0.ebuild:
+ Bump
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> twisted-conch-9.0.0.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #300702
diff --git a/dev-python/twisted-conch/twisted-conch-10.0.0.ebuild b/dev-python/twisted-conch/twisted-conch-10.0.0.ebuild
new file mode 100644
index 000000000000..fcd3bcb5050b
--- /dev/null
+++ b/dev-python/twisted-conch/twisted-conch-10.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-10.0.0.ebuild,v 1.1 2010/03/17 10:39:45 patrick Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+MY_PACKAGE="Conch"
+
+inherit twisted versionator
+
+DESCRIPTION="Twisted SSHv2 implementation"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1-2)*
+ >=dev-python/pycrypto-1.9_alpha6"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="twisted/conch twisted/plugins"
+
+src_prepare() {
+ distutils_src_prepare
+ # These tests sometimes fail with "reason 11, desc: disconnected by user".
+ sed -e "s/test_extendedAttributes/_&/" -i twisted/conch/test/test_cftp.py || die "sed failed"
+ sed -e "s/test_exec/_&/" -i twisted/conch/test/test_conch.py || die "sed failed"
+}