summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-04 21:07:02 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-04 21:07:02 +0000
commitbce4c93152b600e6a4995ef16a38ca00911d9237 (patch)
treee04ff6ac9a986abcaa45b6c3e54ec158a75d18cc /dev-python/twisted-words/twisted-words-11.0.0.ebuild
parentmaintain this package, remove old versions (diff)
downloadhistorical-bce4c93152b600e6a4995ef16a38ca00911d9237.tar.gz
historical-bce4c93152b600e6a4995ef16a38ca00911d9237.tar.bz2
historical-bce4c93152b600e6a4995ef16a38ca00911d9237.zip
Version bump.
Package-Manager: portage-2.2.0_alpha29_p8/cvs/Linux x86_64
Diffstat (limited to 'dev-python/twisted-words/twisted-words-11.0.0.ebuild')
-rw-r--r--dev-python/twisted-words/twisted-words-11.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/twisted-words/twisted-words-11.0.0.ebuild b/dev-python/twisted-words/twisted-words-11.0.0.ebuild
new file mode 100644
index 000000000000..21046dc1bb43
--- /dev/null
+++ b/dev-python/twisted-words/twisted-words-11.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-11.0.0.ebuild,v 1.1 2011/04/04 21:07:02 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+MY_PACKAGE="Words"
+
+inherit twisted
+
+DESCRIPTION="Twisted Words contains Instant Messaging implementations."
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1)*
+ =dev-python/twisted-web-$(get_version_component_range 1)*"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="twisted/plugins twisted/words"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Delete documentation for no longer available "im" script.
+ rm -fr doc/man
+}