summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-05-02 04:08:56 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-05-02 04:08:56 +0000
commit76147b1dde1e1b5c00e857f36db1b8b86f9d9fa7 (patch)
tree5a1864ea5f73f61792ea136540e79145386ca8bf /dev-python/webhelpers/webhelpers-0.3.4.ebuild
parentadd .dll to the fugly list (diff)
downloadhistorical-76147b1dde1e1b5c00e857f36db1b8b86f9d9fa7.tar.gz
historical-76147b1dde1e1b5c00e857f36db1b8b86f9d9fa7.tar.bz2
historical-76147b1dde1e1b5c00e857f36db1b8b86f9d9fa7.zip
Version bump. Added dep for dev-python/coverage, removed broken pudge build in 0.3.4
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'dev-python/webhelpers/webhelpers-0.3.4.ebuild')
-rw-r--r--dev-python/webhelpers/webhelpers-0.3.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/webhelpers/webhelpers-0.3.4.ebuild b/dev-python/webhelpers/webhelpers-0.3.4.ebuild
new file mode 100644
index 000000000000..9510abbda415
--- /dev/null
+++ b/dev-python/webhelpers/webhelpers-0.3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webhelpers/webhelpers-0.3.4.ebuild,v 1.1 2008/05/02 04:08:56 pythonhead Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=WebHelpers
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A library of helper functions intended to make writing templates in web applications easier."
+HOMEPAGE="http://pylonshq.com/WebHelpers/"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/simplejson-1.4
+ >=dev-python/routes-1.8"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose dev-python/coverage )
+ dev-python/setuptools"
+
+S=${WORKDIR}/${MY_P}
+
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
+}